aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2016-01-24 12:36:10 +0000
committerJonas Gorski <jogo@openwrt.org>2016-01-24 12:36:10 +0000
commitca353b07da6d8cd82e90f79fb600787b12128011 (patch)
treec3fab6504b856a0c369a26d3029694d547da76c2 /target/linux/brcm63xx
parent714c9d931c8b06547b67a2ac41f30fd045a98801 (diff)
downloadmaster-187ad058-ca353b07da6d8cd82e90f79fb600787b12128011.tar.gz
master-187ad058-ca353b07da6d8cd82e90f79fb600787b12128011.tar.bz2
master-187ad058-ca353b07da6d8cd82e90f79fb600787b12128011.zip
brcm63xx: fix build of lzma-loader with binutils 2.25.1
Apply the same fix as ar71xx needed in r46893. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48473 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/lzma-loader/src/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/lzma-loader/src/Makefile b/target/linux/brcm63xx/image/lzma-loader/src/Makefile
index 50c22d8b29..167bf6455a 100644
--- a/target/linux/brcm63xx/image/lzma-loader/src/Makefile
+++ b/target/linux/brcm63xx/image/lzma-loader/src/Makefile
@@ -24,7 +24,8 @@ LD := $(CROSS_COMPILE)ld
OBJCOPY := $(CROSS_COMPILE)objcopy
OBJDUMP := $(CROSS_COMPILE)objdump
-BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
+ -R .MIPS.abiflags -S
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \