aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-05-27 13:22:22 +0000
committerJonas Gorski <jogo@openwrt.org>2012-05-27 13:22:22 +0000
commitafb39de7d0910eab1d54d9cab0da8bff7691889b (patch)
treeb9c5f78c78633cace47a3eda420b5f37a2f4ae07 /target/linux/brcm63xx
parent6111884b1c95f81a876f5c3ae2bfcb864bf9af4d (diff)
downloadmaster-187ad058-afb39de7d0910eab1d54d9cab0da8bff7691889b.tar.gz
master-187ad058-afb39de7d0910eab1d54d9cab0da8bff7691889b.tar.bz2
master-187ad058-afb39de7d0910eab1d54d9cab0da8bff7691889b.zip
bcm63xx: pad Speedport W303 V images to 4 MiB
Prevents CFE from flashing to the second image offset. Fix up the rootfs length on first boot else CFE will complain. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31876 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index f82647e983..303003c793 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -93,7 +93,7 @@ define Image/Build/SPW303V
--output $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp \
--boardid $(2) --chipid $(3) --entry $(KERNEL_ENTRY) \
--load-addr $(LOADADDR) --rsa-signature "$(5)" \
- $(6) $(7) $(8) $(9)
+ --pad 4 $(6) $(7) $(8) $(9)
# Fix up header
$(STAGING_DIR_HOST)/bin/spw303v -i $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp \
-o $(BIN_DIR)/openwrt-$(4)-$(1)-cfe-sysupgrade.bin