aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles/netgear.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-02-27 17:39:07 +0000
committerJonas Gorski <jogo@openwrt.org>2015-02-27 17:39:07 +0000
commit36ce877190c577a0a9b66259eef35aa4261a71e2 (patch)
tree9f10ef5f94e68410af16e67e608b065fbe4dccf0 /target/linux/brcm63xx/profiles/netgear.mk
parent84d3d8799f258cfa4ca7586142d30324f733cef1 (diff)
downloadmaster-187ad058-36ce877190c577a0a9b66259eef35aa4261a71e2.tar.gz
master-187ad058-36ce877190c577a0a9b66259eef35aa4261a71e2.tar.bz2
master-187ad058-36ce877190c577a0a9b66259eef35aa4261a71e2.zip
brcm63xx: use dtb for cvg834g
Add a dtsi for bcm3368, add a dts and profile for cvg834g, and convert it to use ImageDTB. Since HCS requires more arguments, enhance the max arguments of the call. The image name is intentionally left blank to prevent non-initramfs images to be built, as they currently contain no rootfs and consequently won't work. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44561 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/profiles/netgear.mk')
-rw-r--r--target/linux/brcm63xx/profiles/netgear.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/netgear.mk b/target/linux/brcm63xx/profiles/netgear.mk
index 562e0f5969..75ddab53ce 100644
--- a/target/linux/brcm63xx/profiles/netgear.mk
+++ b/target/linux/brcm63xx/profiles/netgear.mk
@@ -5,6 +5,16 @@
# See /LICENSE for more information.
#
+define Profile/CVG834G
+ NAME:=Netgear CVG834G
+ PACKAGES:=
+endef
+define Profile/CVG834G/Description
+ Package set optimized for CVG834G.
+endef
+
+$(eval $(call Profile,CVG834G))
+
define Profile/DG834GTPN
NAME:=Netgear DG834GT/PN
PACKAGES:=kmod-ath5k wpad-mini