aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/patches
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-11-15 11:21:42 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-11-15 11:21:42 +0000
commit691021f3bbd2fc1c451e6ed9af840585ea7ab548 (patch)
tree18e3915ee612328a9a1a17deaf7bc6f4ad63e1dd /target/linux/brcm63xx/patches
parent57b30892410a9608b5b6434e64fe5c8a8657fbc3 (diff)
downloadmaster-187ad058-691021f3bbd2fc1c451e6ed9af840585ea7ab548.tar.gz
master-187ad058-691021f3bbd2fc1c451e6ed9af840585ea7ab548.tar.bz2
master-187ad058-691021f3bbd2fc1c451e6ed9af840585ea7ab548.zip
Delete old brcm63xx files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13210 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/patches')
-rw-r--r--target/linux/brcm63xx/patches/001-bcm963xx.patch153
-rw-r--r--target/linux/brcm63xx/patches/002-bcm963xx_serial.patch9
-rw-r--r--target/linux/brcm63xx/patches/040-bcm963xx_flashmap.patch66
3 files changed, 0 insertions, 228 deletions
diff --git a/target/linux/brcm63xx/patches/001-bcm963xx.patch b/target/linux/brcm63xx/patches/001-bcm963xx.patch
deleted file mode 100644
index 4dae0ac7f6..0000000000
--- a/target/linux/brcm63xx/patches/001-bcm963xx.patch
+++ /dev/null
@@ -1,153 +0,0 @@
-Index: linux-2.6.24.7/arch/mips/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/Kconfig
-+++ linux-2.6.24.7/arch/mips/Kconfig
-@@ -67,6 +67,17 @@ config BCM47XX
- help
- Support for BCM47XX based boards
-
-+config BCM963XX
-+ bool "Support for Broadcom BCM963xx SoC"
-+ select SYS_SUPPORTS_32BIT_KERNEL
-+ select SYS_SUPPORTS_BIG_ENDIAN
-+ select SYS_HAS_CPU_MIPS32_R1
-+ select HW_HAS_PCI
-+ select DMA_NONCOHERENT
-+ select IRQ_CPU
-+ help
-+ This is a fmaily of boards based on the Broadcom MIPS32
-+
- config MIPS_COBALT
- bool "Cobalt Server"
- select CEVT_R4K
-Index: linux-2.6.24.7/arch/mips/kernel/cpu-probe.c
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/kernel/cpu-probe.c
-+++ linux-2.6.24.7/arch/mips/kernel/cpu-probe.c
-@@ -796,6 +796,18 @@ static inline void cpu_probe_broadcom(st
- case PRID_IMP_BCM4710:
- c->cputype = CPU_BCM4710;
- break;
-+// case PRID_IMP_BCM6338:
-+// c->cputype = CPU_BCM6338;
-+// break;
-+ case PRID_IMP_BCM6345:
-+ c->cputype = CPU_BCM6345;
-+ break;
-+ case PRID_IMP_BCM6348:
-+ c->cputype = CPU_BCM6348;
-+ break;
-+ case PRID_IMP_BCM6358:
-+ c->cputype = CPU_BCM6358;
-+ break;
- default:
- c->cputype = CPU_UNKNOWN;
- break;
-@@ -878,6 +890,10 @@ static __init const char *cpu_to_name(st
- case CPU_SR71000: name = "Sandcraft SR71000"; break;
- case CPU_BCM3302: name = "Broadcom BCM3302"; break;
- case CPU_BCM4710: name = "Broadcom BCM4710"; break;
-+ case CPU_BCM6338: name = "Broadcom BCM6338"; break;
-+ case CPU_BCM6345: name = "Broadcom BCM6345"; break;
-+ case CPU_BCM6348: name = "Broadcom BCM6348"; break;
-+ case CPU_BCM6358: name = "Broadcom BCM6358"; break;
- case CPU_PR4450: name = "Philips PR4450"; break;
- case CPU_LOONGSON2: name = "ICT Loongson-2"; break;
- default:
-Index: linux-2.6.24.7/arch/mips/Makefile
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/Makefile
-+++ linux-2.6.24.7/arch/mips/Makefile
-@@ -543,6 +543,10 @@ core-$(CONFIG_BCM47XX) += arch/mips/bcm
- cflags-$(CONFIG_BCM47XX) += -Iinclude/asm-mips/mach-bcm47xx
- load-$(CONFIG_BCM47XX) := 0xffffffff80001000
-
-+core-$(CONFIG_BCM963XX) += arch/mips/bcm963xx/
-+cflags-$(CONFIG_BCM963XX) += -Iinclude/asm-mips/mach-bcm963xx
-+load-$(CONFIG_BCM963XX) := 0xffffffff8001000
-+
- #
- # SNI RM
- #
-Index: linux-2.6.24.7/arch/mips/mm/c-r4k.c
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/mm/c-r4k.c
-+++ linux-2.6.24.7/arch/mips/mm/c-r4k.c
-@@ -878,6 +878,13 @@ static void __init probe_pcache(void)
- if (!(config & MIPS_CONF_M))
- panic("Don't know how to probe P-caches on this cpu.");
-
-+ if (c->cputype == CPU_BCM6338 || c->cputype == CPU_BCM6345 || c->cputype == CPU_BCM6348 || c->cputype == CPU_BCM6358)
-+ {
-+ printk("bcm963xx: enabling icache and dcache...\n");
-+ /* Enable caches */
-+ write_c0_diag(read_c0_diag() | 0xC0000000);
-+ }
-+
- /*
- * So we seem to be a MIPS32 or MIPS64 CPU
- * So let's probe the I-cache ...
-Index: linux-2.6.24.7/arch/mips/mm/tlbex.c
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/mm/tlbex.c
-+++ linux-2.6.24.7/arch/mips/mm/tlbex.c
-@@ -909,6 +909,10 @@ static __init void build_tlb_write_entry
- case CPU_25KF:
- case CPU_BCM3302:
- case CPU_BCM4710:
-+// case CPU_BCM6338:
-+ case CPU_BCM6345:
-+ case CPU_BCM6348:
-+ case CPU_BCM6358:
- case CPU_LOONGSON2:
- if (m4kc_tlbp_war())
- i_nop(p);
-Index: linux-2.6.24.7/arch/mips/pci/Makefile
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/pci/Makefile
-+++ linux-2.6.24.7/arch/mips/pci/Makefile
-@@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
- obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
- obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
- obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
-+obj-$(CONFIG_BCM963XX) += fixup-bcm96348.o pci-bcm96348.o ops-bcm96348.o
-Index: linux-2.6.24.7/include/asm-mips/bootinfo.h
-===================================================================
---- linux-2.6.24.7.orig/include/asm-mips/bootinfo.h
-+++ linux-2.6.24.7/include/asm-mips/bootinfo.h
-@@ -197,6 +197,10 @@
- */
- #define MACH_GROUP_BRCM 23 /* Broadcom */
- #define MACH_BCM47XX 1 /* Broadcom BCM47XX */
-+#define MACH_BCM96338 2
-+#define MACH_BCM96345 3
-+#define MACH_BCM96348 4
-+#define MACH_BCM96358 5
-
- #define CL_SIZE COMMAND_LINE_SIZE
-
-Index: linux-2.6.24.7/include/asm-mips/cpu.h
-===================================================================
---- linux-2.6.24.7.orig/include/asm-mips/cpu.h
-+++ linux-2.6.24.7/include/asm-mips/cpu.h
-@@ -111,6 +111,10 @@
-
- #define PRID_IMP_BCM4710 0x4000
- #define PRID_IMP_BCM3302 0x9000
-+//#define PRID_IMP_BCM6338 0x9000
-+#define PRID_IMP_BCM6345 0x8000
-+#define PRID_IMP_BCM6348 0x9100
-+#define PRID_IMP_BCM6358 0xA000
-
- /*
- * Definitions for 7:0 on legacy processors
-@@ -196,7 +200,8 @@ enum cpu_type_enum {
- */
- CPU_4KC, CPU_4KEC, CPU_4KSC, CPU_24K, CPU_34K, CPU_74K, CPU_AU1000,
- CPU_AU1100, CPU_AU1200, CPU_AU1500, CPU_AU1550, CPU_PR4450,
-- CPU_BCM3302, CPU_BCM4710,
-+ CPU_BCM3302, CPU_BCM4710, CPU_BCM6338, CPU_BCM6345, CPU_BCM6348,
-+ CPU_BCM6358,
-
- /*
- * MIPS64 class processors
diff --git a/target/linux/brcm63xx/patches/002-bcm963xx_serial.patch b/target/linux/brcm63xx/patches/002-bcm963xx_serial.patch
deleted file mode 100644
index dbcf30e70c..0000000000
--- a/target/linux/brcm63xx/patches/002-bcm963xx_serial.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-Index: linux-2.6.24.7/drivers/serial/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/serial/Makefile
-+++ linux-2.6.24.7/drivers/serial/Makefile
-@@ -65,3 +65,4 @@ obj-$(CONFIG_SERIAL_NETX) += netx-serial
- obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
- obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
- obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
-+obj-$(CONFIG_BCM963XX) += bcm63xx_cons.o
diff --git a/target/linux/brcm63xx/patches/040-bcm963xx_flashmap.patch b/target/linux/brcm63xx/patches/040-bcm963xx_flashmap.patch
deleted file mode 100644
index 7a62fffa3c..0000000000
--- a/target/linux/brcm63xx/patches/040-bcm963xx_flashmap.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-Index: linux-2.6.24.7/drivers/mtd/maps/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/maps/Kconfig
-+++ linux-2.6.24.7/drivers/mtd/maps/Kconfig
-@@ -269,6 +269,13 @@ config MTD_MTX1
- Flash memory access on 4G Systems MTX-1 Board. If you have one of
- these boards and would like to use the flash chips on it, say 'Y'.
-
-+config MTD_BCM963XX
-+ tristate "BCM963xx Flash device"
-+ depends on MIPS && BCM963XX
-+ help
-+ Flash memory access on BCM963xx boards. Currently only works with
-+ RedBoot and CFE.
-+
- config MTD_DILNETPC
- tristate "CFI Flash device mapped on DIL/Net PC"
- depends on X86 && MTD_CONCAT && MTD_PARTITIONS && MTD_CFI_INTELEXT
-Index: linux-2.6.24.7/drivers/mtd/redboot.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/redboot.c
-+++ linux-2.6.24.7/drivers/mtd/redboot.c
-@@ -39,7 +39,7 @@ static inline int redboot_checksum(struc
- return 1;
- }
-
--static int parse_redboot_partitions(struct mtd_info *master,
-+int parse_redboot_partitions(struct mtd_info *master,
- struct mtd_partition **pparts,
- unsigned long fis_origin)
- {
-@@ -146,6 +146,14 @@ static int parse_redboot_partitions(stru
- goto out;
- }
-
-+ if (!fis_origin) {
-+ for (i = 0; i < numslots; i++) {
-+ if (!strncmp(buf[i].name, "RedBoot", 8)) {
-+ fis_origin = (buf[i].flash_base & (master->size << 1) - 1);
-+ }
-+ }
-+ }
-+
- for (i = 0; i < numslots; i++) {
- struct fis_list *new_fl, **prev;
-
-@@ -168,9 +176,8 @@ static int parse_redboot_partitions(stru
- new_fl->img = &buf[i];
- if (fis_origin) {
- buf[i].flash_base -= fis_origin;
-- } else {
-- buf[i].flash_base &= master->size-1;
- }
-+ buf[i].flash_base &= (master->size << 1) - 1;
-
- /* I'm sure the JFFS2 code has done me permanent damage.
- * I now think the following is _normal_
-Index: linux-2.6.24.7/drivers/mtd/maps/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/maps/Makefile
-+++ linux-2.6.24.7/drivers/mtd/maps/Makefile
-@@ -69,3 +69,4 @@ obj-$(CONFIG_MTD_PLATRAM) += plat-ram.o
- obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
- obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
- obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
-+obj-$(CONFIG_MTD_BCM963XX) += bcm963xx-flash.o