aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-03-12 08:54:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-03-12 08:54:04 +0000
commit4750ec9396662d2c0024ad853e3fc854bab04f48 (patch)
tree5dc9add87608aea897d2ba4e3c03c875a5bc70d7 /target/linux/brcm63xx/image
parent4b5f21833cb090fe7893e7604823ef3676a11ee6 (diff)
downloadmaster-187ad058-4750ec9396662d2c0024ad853e3fc854bab04f48.tar.gz
master-187ad058-4750ec9396662d2c0024ad853e3fc854bab04f48.tar.bz2
master-187ad058-4750ec9396662d2c0024ad853e3fc854bab04f48.zip
[brcm63xx] add support for AGPF-S0 (Pirelli Alice Gate VoIP 2 Plus Wi-Fi) #4366
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14850 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/image')
-rw-r--r--target/linux/brcm63xx/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 6cb7a34c01..250cc8236d 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -37,6 +37,15 @@ define Image/Build/CFE
$(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
endef
+define Image/Build/CFEAGPF
+ # Generate the tagged image
+ $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
+ -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
+ -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR) \
+ -v 8 -m IMAGE -k 131072
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
+endef
+
define Image/Build/RedBoot
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(1)-vmlinux.elf
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
@@ -104,6 +113,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),F@ST2404,6348)
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
+ # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
+ $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358)
endef
$(eval $(call BuildImage))