aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:59 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:59 +0000
commit1e7bcd00a970963a1f759fa47ef7dc64c2c6706a (patch)
treed38ee771478d09c23daa070be07d5489e5ae5c55 /target/linux/brcm63xx/image
parented7bef4f55a8a5ec4c37fdaff263541f978888b4 (diff)
downloadmaster-187ad058-1e7bcd00a970963a1f759fa47ef7dc64c2c6706a.tar.gz
master-187ad058-1e7bcd00a970963a1f759fa47ef7dc64c2c6706a.tar.bz2
master-187ad058-1e7bcd00a970963a1f759fa47ef7dc64c2c6706a.zip
brcm63xx: move kernel load address to 8MiB
Fixes boot when uncompressed kernel is > 4 MiB (#19251). Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44984 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/image')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 47756bf39b..a55fc46d6c 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-LOADADDR = 0x80010000 # RAM start + 64K
+LOADADDR = 0x80800000 # RAM start + 8MB
KERNEL_ENTRY = $(LOADADDR) # Newer kernels add a jmp to the kernel_entry at the start of the binary
RAMSIZE = 0x02000000 # 32MB
LZMA_TEXT_START = 0x81800000 # 32MB - 8MB