aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/generic/profiles/200-GW6X00.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-02 15:28:31 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-02 15:28:31 +0000
commit1780aae0a88de1b039db06b0b27b566a9813f76e (patch)
tree57e2c2cf8c74ed149c696894980ea65e1af5617b /target/linux/brcm63xx/generic/profiles/200-GW6X00.mk
parentdec4629f2753e8fdcc69584be9d326d5a24c1841 (diff)
downloadmaster-187ad058-1780aae0a88de1b039db06b0b27b566a9813f76e.tar.gz
master-187ad058-1780aae0a88de1b039db06b0b27b566a9813f76e.tar.bz2
master-187ad058-1780aae0a88de1b039db06b0b27b566a9813f76e.zip
bcm63xx: split into two subtargets, generic and SMP
Make SMP a subtarget, since it only supports BCM6362 and BCM6368. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36527 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/generic/profiles/200-GW6X00.mk')
-rw-r--r--target/linux/brcm63xx/generic/profiles/200-GW6X00.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/generic/profiles/200-GW6X00.mk b/target/linux/brcm63xx/generic/profiles/200-GW6X00.mk
new file mode 100644
index 0000000000..1cb763dac1
--- /dev/null
+++ b/target/linux/brcm63xx/generic/profiles/200-GW6X00.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/GW6X00
+ NAME:=Tecom GW6X00
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb-storage \
+ kmod-fs-ext4 kmod-nls-cp437 kmod-nls-iso8859-1 e2fsprogs \
+ kmod-ipt-nathelper-extra wlc
+endef
+
+define Profile/GW6X00/Description
+ Package set compatible with the Tecom GW6000 and GW6200 based
+ on the BCM96348GW reference design.
+endef
+$(eval $(call Profile,GW6X00))
+