aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-01-24 14:38:10 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-01-24 14:38:10 +0000
commit25ebb1738fad3d0ca53027c985b2a2886804af2d (patch)
treec5689a597591396e3f99bace70906c4bd4c3e291 /target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk
parent264698349696d8b3ec93c8f476e084c5aca0b00c (diff)
downloadmaster-187ad058-25ebb1738fad3d0ca53027c985b2a2886804af2d.tar.gz
master-187ad058-25ebb1738fad3d0ca53027c985b2a2886804af2d.tar.bz2
master-187ad058-25ebb1738fad3d0ca53027c985b2a2886804af2d.zip
brcm47xx: change generic profiles
The default profile now contains Ethernet drivers for all the types found on supported boards. There are other profiles for each Ethernet driver. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35314 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk')
-rw-r--r--target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk b/target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk
new file mode 100644
index 0000000000..55d729a5b7
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b44-ath5k
+ NAME:=Broadcom SoC, b44 Ethernet, Atheros WiFi (ath5k)
+ PACKAGES:=kmod-b44 kmod-ath5k
+endef
+
+define Profile/Broadcom-b44-ath5k/Description
+ Package set compatible with hardware older Broadcom BCM47xx or BCM535x
+ SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
+ b44 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-b44-ath5k))
+