aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/modules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:33 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:33 +0000
commit6566d706be3b33c89bc86cba1ad6f8e2efebc4df (patch)
tree72eba6fd0bf31d8e5c0bce8af754416d459b1e71 /target/linux/brcm47xx/modules.mk
parentdfb32e8ff2340b70a20a75d5047071c7ee20ceae (diff)
downloadmaster-187ad058-6566d706be3b33c89bc86cba1ad6f8e2efebc4df.tar.gz
master-187ad058-6566d706be3b33c89bc86cba1ad6f8e2efebc4df.tar.bz2
master-187ad058-6566d706be3b33c89bc86cba1ad6f8e2efebc4df.zip
[brcm47xx] move usb driver to target specific modules.mk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32861 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/modules.mk')
-rw-r--r--target/linux/brcm47xx/modules.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/modules.mk b/target/linux/brcm47xx/modules.mk
new file mode 100644
index 0000000000..a7e25fd3b4
--- /dev/null
+++ b/target/linux/brcm47xx/modules.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/usb-brcm47xx
+ SUBMENU:=$(USB_MENU)
+ TITLE:=Support for USB on bcm47xx
+ DEPENDS:=@USB_SUPPORT @TARGET_brcm47xx
+ KCONFIG:= \
+ CONFIG_USB_HCD_BCMA \
+ CONFIG_USB_HCD_SSB
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/host/bcma-hcd.ko \
+ $(LINUX_DIR)/drivers/usb/host/ssb-hcd.ko
+ AUTOLOAD:=$(call AutoLoad,19,bcma-hcd ssb-hcd,1)
+ $(call AddDepends/usb)
+endef
+
+$(eval $(call KernelPackage,usb-brcm47xx))