aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-05 10:27:18 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-05 10:27:18 +0000
commit3700fab7c36c231d2e7764f05d8eb3369d10a8ba (patch)
treeaa1691a28e13cdc49ab187f92ace0935f48c5f0b /target/linux/brcm2708
parent2f050ddec0879b2052603e766f252e74d17fae3b (diff)
downloadmaster-187ad058-3700fab7c36c231d2e7764f05d8eb3369d10a8ba.tar.gz
master-187ad058-3700fab7c36c231d2e7764f05d8eb3369d10a8ba.tar.bz2
master-187ad058-3700fab7c36c231d2e7764f05d8eb3369d10a8ba.zip
brcm2708: fix kmod-sound-soc-bcm2708-i2s config
Right now, selecting kmod-sound-soc-bcm2708-i2s causes build errors due to missing configs. kmod-regmap enables I2C and SPI, causing build errors due to depending variables not defined. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47123 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/modules.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm2708/modules.mk b/target/linux/brcm2708/modules.mk
index 68a7d38028..9c201d0997 100644
--- a/target/linux/brcm2708/modules.mk
+++ b/target/linux/brcm2708/modules.mk
@@ -28,6 +28,8 @@ $(eval $(call KernelPackage,sound-arm-bcm2835))
define KernelPackage/sound-soc-bcm2708-i2s
TITLE:=SoC Audio support for the Broadcom 2708 I2S module
KCONFIG:= \
+ CONFIG_BCM2708_SPIDEV=n \
+ CONFIG_MFD_RPISENSE_CORE=n \
CONFIG_SND_BCM2708_SOC_I2S \
CONFIG_SND_SOC_DMAENGINE_PCM=y \
CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM=y