aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-07-24 20:39:17 +0000
committerJohn Crispin <blogic@openwrt.org>2012-07-24 20:39:17 +0000
commit259cad41cd82fcad082c9a892fa974e46b0f8d24 (patch)
tree6d38108969c18ba8fdad3cd124d7d4183adf2263 /target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch
parent68ca3cdc277f72f5f3ee99dd63fba93f8268f6fc (diff)
downloadmaster-187ad058-259cad41cd82fcad082c9a892fa974e46b0f8d24.tar.gz
master-187ad058-259cad41cd82fcad082c9a892fa974e46b0f8d24.tar.bz2
master-187ad058-259cad41cd82fcad082c9a892fa974e46b0f8d24.zip
[brcm2708] adds target used by rapsberry pi
Add support for Raspberry Pi / brcm2708 / 2835 Signed-off-by: Ian Ridge <ianridge [at] gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32825 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch')
-rw-r--r--target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch b/target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch
new file mode 100644
index 0000000000..82b6e067c6
--- /dev/null
+++ b/target/linux/brcm2708/patches-3.3/0510-fix_divdi3.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/lib/Makefile
++++ b/arch/arm/lib/Makefile
+@@ -14,7 +14,7 @@ lib-y := backtrace.o changebit.o csumip
+ ashldi3.o ashrdi3.o lshrdi3.o muldi3.o \
+ ucmpdi2.o lib1funcs.o div64.o \
+ io-readsb.o io-writesb.o io-readsl.o io-writesl.o \
+- call_with_stack.o
++ call_with_stack.o divdi3.o
+
+ mmu-y := clear_user.o copy_page.o getuser.o putuser.o
+