aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.18/0076-BCM2708_DT-Build-the-overlays-as-well.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-11 10:17:55 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-11 10:17:55 +0000
commitc291f76d24a4190551a42b7b77a2cfeb3f4d36f9 (patch)
tree8f9211217d7e2cbaa78d10b596d81e646b3b9aad /target/linux/brcm2708/patches-3.18/0076-BCM2708_DT-Build-the-overlays-as-well.patch
parent0e26998162921c65cbfe2814e500c81ca7b50dad (diff)
downloadmaster-187ad058-c291f76d24a4190551a42b7b77a2cfeb3f4d36f9.tar.gz
master-187ad058-c291f76d24a4190551a42b7b77a2cfeb3f4d36f9.tar.bz2
master-187ad058-c291f76d24a4190551a42b7b77a2cfeb3f4d36f9.zip
brcm2708: update to v3.18
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44392 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/patches-3.18/0076-BCM2708_DT-Build-the-overlays-as-well.patch')
-rwxr-xr-xtarget/linux/brcm2708/patches-3.18/0076-BCM2708_DT-Build-the-overlays-as-well.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/brcm2708/patches-3.18/0076-BCM2708_DT-Build-the-overlays-as-well.patch b/target/linux/brcm2708/patches-3.18/0076-BCM2708_DT-Build-the-overlays-as-well.patch
new file mode 100755
index 0000000000..c28c371532
--- /dev/null
+++ b/target/linux/brcm2708/patches-3.18/0076-BCM2708_DT-Build-the-overlays-as-well.patch
@@ -0,0 +1,43 @@
+From 672e48427ca17fadd59d294eec56476dd6a75398 Mon Sep 17 00:00:00 2001
+From: Phil Elwell <phil@raspberrypi.org>
+Date: Fri, 23 Jan 2015 15:18:03 +0000
+Subject: [PATCH 076/114] BCM2708_DT: Build the overlays as well
+
+---
+ arch/arm/boot/dts/Makefile | 13 +++++++++++++
+ 1 file changed, 13 insertions(+)
+
+diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
+index adaebbb..3c7f539 100644
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -55,6 +55,14 @@ dtb-$(CONFIG_ARCH_ATLAS6) += atlas6-evb.dtb
+ dtb-$(CONFIG_ARCH_AXXIA) += axm5516-amarillo.dtb
+ dtb-$(CONFIG_BCM2708_DT) += bcm2708-rpi-b.dtb
+ dtb-$(CONFIG_BCM2708_DT) += bcm2708-rpi-b-plus.dtb
++dtb-$(CONFIG_BCM2708_DT) += hifiberry-dac-overlay.dtb
++dtb-$(CONFIG_BCM2708_DT) += hifiberry-dacplus-overlay.dtb
++dtb-$(CONFIG_BCM2708_DT) += hifiberry-digi-overlay.dtb
++dtb-$(CONFIG_BCM2708_DT) += iqaudio-dac-overlay.dtb
++dtb-$(CONFIG_BCM2708_DT) += iqaudio-dacplus-overlay.dtb
++dtb-$(CONFIG_BCM2708_DT) += lirc-rpi-overlay.dtb
++dtb-$(CONFIG_BCM2708_DT) += w1-gpio-overlay.dtb
++dtb-$(CONFIG_BCM2708_DT) += w1-gpio-pullup-overlay.dtb
+ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
+ dtb-$(CONFIG_ARCH_BCM_5301X) += bcm4708-netgear-r6250.dtb
+ dtb-$(CONFIG_ARCH_BCM_63XX) += bcm963138dvt.dtb
+@@ -524,6 +532,11 @@ targets += $(dtb-y)
+
+ endif
+
++# Enable fixups to support overlays on BCM2708 platforms
++ifeq ($(CONFIG_BCM2708_DT),y)
++ DTC_FLAGS ?= -@
++endif
++
+ # *.dtb used to be generated in the directory above. Clean out the
+ # old build results so people don't accidentally use them.
+ dtbs: $(addprefix $(obj)/, $(dtb-y))
+--
+1.8.3.2
+