aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-13 07:38:27 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-13 07:38:27 +0000
commit50a4aa688be2e05464d250686df0d4272b3c8c17 (patch)
tree2b2acdd9795e115eaece266c0323367885de17bd /target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
parentdb3443e8953c04280ecfefba9b36aed9176c4abc (diff)
downloadmaster-187ad058-50a4aa688be2e05464d250686df0d4272b3c8c17.tar.gz
master-187ad058-50a4aa688be2e05464d250686df0d4272b3c8c17.tar.bz2
master-187ad058-50a4aa688be2e05464d250686df0d4272b3c8c17.zip
brcm2708: refresh patches
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44433 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch')
-rw-r--r--[-rwxr-xr-x]target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch15
1 files changed, 1 insertions, 14 deletions
diff --git a/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch b/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
index 59a1d9fb09..adaf624be4 100755..100644
--- a/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
+++ b/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
@@ -56,8 +56,6 @@ to avoid the name clash when registering debugfs entries.
create mode 100644 sound/soc/bcm/bcm2708-i2s.c
create mode 100644 sound/soc/bcm/bcm2708-i2s.h
-diff --git a/sound/soc/bcm/Kconfig b/sound/soc/bcm/Kconfig
-index 6a834e1..7e5b945 100644
--- a/sound/soc/bcm/Kconfig
+++ b/sound/soc/bcm/Kconfig
@@ -7,3 +7,14 @@ config SND_BCM2835_SOC_I2S
@@ -75,11 +73,9 @@ index 6a834e1..7e5b945 100644
+ Say Y or M if you want to add support for codecs attached to
+ the BCM2708 I2S interface. You will also need
+ to select the audio interfaces to support below.
-diff --git a/sound/soc/bcm/Makefile b/sound/soc/bcm/Makefile
-index bc816b7..f8bbe1f 100644
--- a/sound/soc/bcm/Makefile
+++ b/sound/soc/bcm/Makefile
-@@ -3,3 +3,7 @@ snd-soc-bcm2835-i2s-objs := bcm2835-i2s.o
+@@ -3,3 +3,7 @@ snd-soc-bcm2835-i2s-objs := bcm2835-i2s.
obj-$(CONFIG_SND_BCM2835_SOC_I2S) += snd-soc-bcm2835-i2s.o
@@ -87,9 +83,6 @@ index bc816b7..f8bbe1f 100644
+snd-soc-bcm2708-i2s-objs := bcm2708-i2s.o
+
+obj-$(CONFIG_SND_BCM2708_SOC_I2S) += snd-soc-bcm2708-i2s.o
-diff --git a/sound/soc/bcm/bcm2708-i2s.c b/sound/soc/bcm/bcm2708-i2s.c
-new file mode 100644
-index 0000000..0b5322a
--- /dev/null
+++ b/sound/soc/bcm/bcm2708-i2s.c
@@ -0,0 +1,998 @@
@@ -1091,9 +1084,6 @@ index 0000000..0b5322a
+MODULE_DESCRIPTION("BCM2708 I2S interface");
+MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
+MODULE_LICENSE("GPL v2");
-diff --git a/sound/soc/bcm/bcm2708-i2s.h b/sound/soc/bcm/bcm2708-i2s.h
-new file mode 100644
-index 0000000..6fdcbc1
--- /dev/null
+++ b/sound/soc/bcm/bcm2708-i2s.h
@@ -0,0 +1,35 @@
@@ -1132,6 +1122,3 @@ index 0000000..6fdcbc1
+extern void bcm2708_i2s_set_gpio(int gpio);
+
+#endif
---
-1.8.3.2
-