aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-17 12:50:52 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-17 12:50:52 +0000
commiteb31fefa1258f60ab358e2b99e547c569928947b (patch)
treebd99907559e8c625ea2a71414361271dd2595e19 /target/linux/brcm2708/image
parent07159abb0fa1753dd6b09199c48f0618b35978b8 (diff)
downloadmaster-187ad058-eb31fefa1258f60ab358e2b99e547c569928947b.tar.gz
master-187ad058-eb31fefa1258f60ab358e2b99e547c569928947b.tar.bz2
master-187ad058-eb31fefa1258f60ab358e2b99e547c569928947b.zip
brcm2708: add gzip image compression
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46404 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index de178c67ea..2afd29b592 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -11,6 +11,16 @@ include $(INCLUDE_DIR)/host.mk
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+ define Image/gzip
+ gzip -9n -c $(1) > $(1).gz
+ mv $(1).gz $(BIN_DIR)
+ endef
+else
+ define Image/gzip
+ endef
+endif
+
### Image scripts ###
define Build/build-dtb
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $@.dtb $(DTS_DIR)/$(DEVICE_DTS).dts
@@ -40,6 +50,7 @@ endef
define Build/sdcard-img
./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
$(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ $(call Image/gzip,$@)
endef
### Device macros ###