aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-05 10:27:41 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-05 10:27:41 +0000
commit2249ee53d92ce3569d7f3accf26374c104705a19 (patch)
tree5856ed6b21101f266847f179f749e7daf3a274c7 /target/linux/brcm2708/image/Makefile
parent328b39121448f658df2bf1652a8245c5e4be3ec9 (diff)
downloadmaster-187ad058-2249ee53d92ce3569d7f3accf26374c104705a19.tar.gz
master-187ad058-2249ee53d92ce3569d7f3accf26374c104705a19.tar.bz2
master-187ad058-2249ee53d92ce3569d7f3accf26374c104705a19.zip
brcm2708: add support for device tree overlays
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47125 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 7a68c506cf..3744cace58 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -21,6 +21,12 @@ else
endef
endif
+define Image/Prepare
+ rm -rf $(KDIR)/overlays
+ mkdir -p $(KDIR)/overlays
+ $(CP) $(DTS_DIR)/overlays/*.dtb $(KDIR)/overlays/
+endef
+
### Image scripts ###
define Build/gen-cfg
cat config.txt > $@.config
@@ -41,6 +47,7 @@ define Build/boot-img
mcopy -i $@.boot $@.config ::config.txt
mcopy -i $@.boot $(word 1,$^) ::kernel.img
mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
+ mcopy -s -i $@.boot $(KDIR)/overlays ::
endef
define Build/sdcard-img