aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/patches
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-01-16 15:11:52 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-01-16 15:11:52 +0000
commita2f3478f7c3bfca01f2b002f8451a8342dc60d67 (patch)
treece81c7290f90e9ce869e21d58104b78c81eb88b0 /target/linux/brcm-2.4/patches
parent35f17d4c9b7e6c69cd2dbcbd41e6bde168699779 (diff)
downloadmaster-187ad058-a2f3478f7c3bfca01f2b002f8451a8342dc60d67.tar.gz
master-187ad058-a2f3478f7c3bfca01f2b002f8451a8342dc60d67.tar.bz2
master-187ad058-a2f3478f7c3bfca01f2b002f8451a8342dc60d67.zip
[brcm-2.4] fix serial flash support (#6442)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19171 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm-2.4/patches')
-rw-r--r--target/linux/brcm-2.4/patches/004-flash.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/brcm-2.4/patches/004-flash.patch b/target/linux/brcm-2.4/patches/004-flash.patch
index f34efb0146..7de8a82eb6 100644
--- a/target/linux/brcm-2.4/patches/004-flash.patch
+++ b/target/linux/brcm-2.4/patches/004-flash.patch
@@ -1,3 +1,13 @@
+--- a/arch/mips/bcm947xx/Makefile
++++ b/arch/mips/bcm947xx/Makefile
+@@ -11,6 +11,7 @@
+ obj-y := prom.o setup.o time.o sbmips.o gpio.o
+ obj-y += nvram.o nvram_linux.o cfe_env.o hndpmu.o
+ obj-y += sbutils.o utils.o bcmsrom.o hndchipc.o
++obj-y += sflash.o
+ obj-$(CONFIG_PCI) += sbpci.o pcibios.o
+ obj-y += export.o
+
--- a/drivers/mtd/devices/Config.in
+++ b/drivers/mtd/devices/Config.in
@@ -5,6 +5,7 @@