aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 18:20:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 18:20:34 +0000
commit2cb1f18c15127d8611cd05038e164be12dac2ba7 (patch)
treea23b6e3878add984d9af143cd9ac06725aad64d1 /target/linux/brcm-2.4/image
parente719e0c4d9fa86ba0d0b907645c9b3dee58647e2 (diff)
downloadmaster-187ad058-2cb1f18c15127d8611cd05038e164be12dac2ba7.tar.gz
master-187ad058-2cb1f18c15127d8611cd05038e164be12dac2ba7.tar.bz2
master-187ad058-2cb1f18c15127d8611cd05038e164be12dac2ba7.zip
clean up a few things in image build makefiles and fix unnecessary grub rebuilds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6360 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm-2.4/image')
-rw-r--r--target/linux/brcm-2.4/image/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/target/linux/brcm-2.4/image/Makefile b/target/linux/brcm-2.4/image/Makefile
index 91cf60ce30..41bd1c89cd 100644
--- a/target/linux/brcm-2.4/image/Makefile
+++ b/target/linux/brcm-2.4/image/Makefile
@@ -7,21 +7,18 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/Compile
- rm -f $(KDIR)/loader.gz
- $(MAKE) -C lzma-loader \
- BUILD_DIR="$(KDIR)" \
- TARGET="$(KDIR)" \
- install
- echo -ne "\\x00" >> $(KDIR)/loader.gz
-endef
-
define Build/Clean
$(MAKE) -C lzma-loader clean
endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+ rm -f $(KDIR)/loader.gz
+ $(MAKE) -C lzma-loader \
+ BUILD_DIR="$(KDIR)" \
+ TARGET="$(KDIR)" \
+ clean install
+ echo -ne "\\x00" >> $(KDIR)/loader.gz
endef
ifneq ($(KERNEL),2.4)