aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-20 12:35:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-20 12:35:00 +0000
commit599cf4f524016ebd16882f7ec64e2aff325d3b82 (patch)
tree8c186144c966717fe2db431c630ff8dcdd16d91b /target/linux/brcm-2.4/Makefile
parentfe2cb26703de11356d8a3089dad47a76eff9337f (diff)
downloadmaster-187ad058-599cf4f524016ebd16882f7ec64e2aff325d3b82.tar.gz
master-187ad058-599cf4f524016ebd16882f7ec64e2aff325d3b82.tar.bz2
master-187ad058-599cf4f524016ebd16882f7ec64e2aff325d3b82.zip
Add WL-700gE support (based on work by jr)
Includes kernel/diag patch and a new target profile git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6142 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm-2.4/Makefile')
-rw-r--r--target/linux/brcm-2.4/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/brcm-2.4/Makefile b/target/linux/brcm-2.4/Makefile
index 0091360c73..28ee7b9205 100644
--- a/target/linux/brcm-2.4/Makefile
+++ b/target/linux/brcm-2.4/Makefile
@@ -112,4 +112,15 @@ define Profile/WLHDD/Description
endef
$(eval $(call Profile,WLHDD))
+define Profile/WL700GE
+ NAME:=WL-700gE
+ PACKAGES:=-ppp -ppp-mod-pppoe -kmod-ipt-nathelper -iptables -dnsmasq -bridge kmod-ide-core kmod-ide-aec62xx kmod-fs-ext3 fdisk e2fsprogs
+endef
+
+define Profile/WL700GE/Description
+ Minimal package set optimized for booting the WL-700gE from flash with a writable filesystem
+ and the utilities to create a new filesystem on the HDD
+endef
+$(eval $(call Profile,WL700GE))
+
$(eval $(call BuildKernel))