aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-06 18:39:06 +0000
commit795a8780e002e1993178d183d884b4ecd2a5363d (patch)
tree03054d81d3d5018e0ce063dffedc37f0a0665296 /target/linux/bcm53xx
parenteb5b5acffb4870d0cb25536e1a44bd9143732992 (diff)
downloadmaster-187ad058-795a8780e002e1993178d183d884b4ecd2a5363d.tar.gz
master-187ad058-795a8780e002e1993178d183d884b4ecd2a5363d.tar.bz2
master-187ad058-795a8780e002e1993178d183d884b4ecd2a5363d.zip
targets: add kernel image dependencies on device tree files
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48146 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index c9987dddc7..d9d4a80fa1 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -67,6 +67,7 @@ define Device/Default
# extract the full dtb name based on the device info
DT := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
KERNEL := kernel-bin | append-dtb | lzma-d16
+ KERNEL_DEPENDS = $$(wildcard $(KDIR)/$$(DT).dts)
FILESYSTEMS := squashfs
KERNEL_NAME := zImage
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)