aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-04-12 11:59:07 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-04-12 11:59:07 +0000
commit0e6867db1e9a2feb6ded27a33631e25f6c18e11e (patch)
tree5689460cf1b5a04c4b83e21e9e627d528f393cd9 /target/linux/bcm53xx
parent9aa3da569edfc91995fbb4bf030d40cce3f0b45e (diff)
downloadmaster-187ad058-0e6867db1e9a2feb6ded27a33631e25f6c18e11e.tar.gz
master-187ad058-0e6867db1e9a2feb6ded27a33631e25f6c18e11e.tar.bz2
master-187ad058-0e6867db1e9a2feb6ded27a33631e25f6c18e11e.zip
kernel: update 3.10 to 3.10.36
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40467 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx')
-rw-r--r--target/linux/bcm53xx/Makefile2
-rw-r--r--target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
index edcf137561..339e7cddb8 100644
--- a/target/linux/bcm53xx/Makefile
+++ b/target/linux/bcm53xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci pcie gpio
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
CPU_TYPE:=cortex-a9
-LINUX_VERSION:=3.10.34
+LINUX_VERSION:=3.10.36
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch b/target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch
index 78154707e7..c23e205218 100644
--- a/target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch
+++ b/target/linux/bcm53xx/patches-3.10/202-bgmac-make-bgmac-work-on-systems-without-nvram.patch
@@ -31,7 +31,7 @@ The PHY says it is not connected by default, just ignore it.
static const struct bcma_device_id bgmac_bcma_tbl[] = {
BCMA_CORE(BCMA_MANUF_BCM, BCMA_CORE_4706_MAC_GBIT, BCMA_ANY_REV, BCMA_ANY_CLASS),
-@@ -1438,7 +1442,7 @@ static int bgmac_probe(struct bcma_devic
+@@ -1452,7 +1456,7 @@ static int bgmac_probe(struct bcma_devic
int err;
/* We don't support 2nd, 3rd, ... units, SPROM has to be adjusted */
@@ -40,7 +40,7 @@ The PHY says it is not connected by default, just ignore it.
pr_err("Unsupported core_unit %d\n", core->core_unit);
return -ENOTSUPP;
}
-@@ -1473,8 +1477,7 @@ static int bgmac_probe(struct bcma_devic
+@@ -1487,8 +1491,7 @@ static int bgmac_probe(struct bcma_devic
}
bgmac->cmn = core->bus->drv_gmac_cmn.core;
@@ -50,7 +50,7 @@ The PHY says it is not connected by default, just ignore it.
bgmac->phyaddr &= BGMAC_PHY_MASK;
if (bgmac->phyaddr == BGMAC_PHY_MASK) {
bgmac_err(bgmac, "No PHY found\n");
-@@ -1526,8 +1529,7 @@ static int bgmac_probe(struct bcma_devic
+@@ -1540,8 +1543,7 @@ static int bgmac_probe(struct bcma_devic
/* TODO: reset the external phy. Specs are needed */
bgmac_phy_reset(bgmac);