aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-04-21 08:42:41 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-04-21 08:42:41 +0000
commitc83e2426c83a10a5f533a3b0fad0b4b6a5d96bbc (patch)
treed9126fe78a8f4164759b1ad572ae75ab9abe89f8 /target/linux/bcm53xx/image
parentec18c9f6c2a63458e38b99307b229b78b133e647 (diff)
downloadmaster-187ad058-c83e2426c83a10a5f533a3b0fad0b4b6a5d96bbc.tar.gz
master-187ad058-c83e2426c83a10a5f533a3b0fad0b4b6a5d96bbc.tar.bz2
master-187ad058-c83e2426c83a10a5f533a3b0fad0b4b6a5d96bbc.zip
bcm53xx: image: prepare for generating serial flash images
There are some rare devices without NAND, like Netgear EX6200 or TP-LINK Archer C8. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45545 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx/image')
-rw-r--r--target/linux/bcm53xx/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index fb909c4629..b299f38949 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -34,6 +34,13 @@ define Build/mkfs/squashfs
( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
endef
+define Build/trx-serial
+ $(STAGING_DIR_HOST)/bin/trx \
+ -o $@ \
+ -f $(word 1,$^) -a 1024 \
+ -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
+endef
+
define Build/trx-nand
# kernel: always use 4 MiB (-28 B or TRX header) to allow upgrades even
# if it grows up between releases