aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/image/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-10-09 16:36:51 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-10-09 16:36:51 +0000
commit4e13eeec5b2fe185ac3a636babecd6f9a4f7ca07 (patch)
tree2f1af73da3806c60d2e8fa035085221adf99c89d /target/linux/bcm53xx/image/Makefile
parente980967a2c90a7c0a67fff9fb50874f5262aabfc (diff)
downloadmaster-187ad058-4e13eeec5b2fe185ac3a636babecd6f9a4f7ca07.tar.gz
master-187ad058-4e13eeec5b2fe185ac3a636babecd6f9a4f7ca07.tar.bz2
master-187ad058-4e13eeec5b2fe185ac3a636babecd6f9a4f7ca07.zip
bcm53xx: prepare to support Asus RT-N18U
DT file doesn't include any GPIOs yet, but let's add it as we got some interest in this device on IRC. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42864 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx/image/Makefile')
-rw-r--r--target/linux/bcm53xx/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 4f22598861..968388380a 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -39,6 +39,15 @@ endef
# $(1): filesystem type (e.g. squashfs, initramfs).
# $(2): dts filename (also used for the firmware file).
+# $(3): device specific magic.
+define Image/Build/AsusTrx
+ $(call Image/Build/$(1)/DTB,$(2))
+ # TODO: Put magic in TRX file
+ cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
+endef
+
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
define Image/Build/Trx
$(call Image/Build/$(1)/DTB,$(2))
cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
@@ -55,6 +64,8 @@ endef
# $(1): filesystem type (e.g. squashfs, initramfs).
define Image/Build
+ $(call Image/Build/AsusTrx,$(1),bcm47081-asus-rt-n18u,RT-N18U)
+
$(call Image/Build/Trx,$(1),bcm4708-buffalo-wzr-1750dhp)
$(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,U12H245T00_NETGEAR,1)