aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-07-12 13:46:27 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-07-12 13:46:27 +0000
commit21201be1f4a0b915ef8c32ae34afefff58d4f42c (patch)
tree42e9e85c31ce67c40103d9267bda76e5fa957bf6 /target/linux/bcm53xx/Makefile
parent089d2c0e73fb6cbcbedd7d1cfc03b183c7075fd9 (diff)
downloadmaster-187ad058-21201be1f4a0b915ef8c32ae34afefff58d4f42c.tar.gz
master-187ad058-21201be1f4a0b915ef8c32ae34afefff58d4f42c.tar.bz2
master-187ad058-21201be1f4a0b915ef8c32ae34afefff58d4f42c.zip
bcm53xx: add initial support for ARM based BCM47XX and BCM53XX SoCs
This was only tested on a Netgear R6250, but it could also work on other devices when the correct images are generated. It is only possible to boot into a ram disk, no Ethernet, Wifi, flash, USB is supported. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37268 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/bcm53xx/Makefile')
-rw-r--r--target/linux/bcm53xx/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/Makefile b/target/linux/bcm53xx/Makefile
new file mode 100644
index 0000000000..ea3a3326bc
--- /dev/null
+++ b/target/linux/bcm53xx/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=bcm53xx
+BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
+FEATURES:=squashfs usb pci pcie gpio
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
+
+LINUX_VERSION:=3.10
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
+endef
+
+CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfp -mfloat-abi=softfp
+
+KERNELNAME:="zImage dtbs"
+
+DEFAULT_PACKAGES +=
+
+$(eval $(call BuildTarget))