aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
commit9958378c233871745b6042df411f7ea8b3fa6d28 (patch)
tree249776c430feb12ac575182a62b558e500f652c4 /target/linux/au1000
parent7fef288830cda93409865932782ce493b56a4d69 (diff)
downloadmaster-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.tar.gz
master-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.tar.bz2
master-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.zip
image: fix jffs2(_nand) image generation
Variables dependend on JFFS2_BLOCKSIZE and NANDBLOCK_SIZE are used for template generation, so need to be present before inclusion of image.mk in target image Makefiles. So move all declarations to before any includes. Fixes: r42878 ("image.mk: clean up and parallelize mkfs calls") Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46564 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/au1000')
-rw-r--r--target/linux/au1000/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/au1000/image/Makefile b/target/linux/au1000/image/Makefile
index 3d5752930f..744e5c64e9 100644
--- a/target/linux/au1000/image/Makefile
+++ b/target/linux/au1000/image/Makefile
@@ -4,6 +4,9 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+JFFS2_BLOCKSIZE = 128k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
@@ -11,8 +14,6 @@ LOADADDR = 0x81000000 # RAM start + 16M
KERNEL_ENTRY = 0x80100000
RAMSIZE = 0x00100000 # 1MB
-JFFS2_BLOCKSIZE = 128k
-
FLASH_KERNEL := 0xBFD00000
FLASH_FS := 0xBE000000