aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-26 07:19:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-26 07:19:58 +0000
commit0a80570a9c0d3ee0ca223e50ce149b1944393f7b (patch)
treed5cedec9dca6d08d75cd6f3e716c72a67e9d75cf /target/linux/atheros
parent0ec41bc74eaedc98a8324bbfa006389e2b8ca22b (diff)
downloadmaster-187ad058-0a80570a9c0d3ee0ca223e50ce149b1944393f7b.tar.gz
master-187ad058-0a80570a9c0d3ee0ca223e50ce149b1944393f7b.tar.bz2
master-187ad058-0a80570a9c0d3ee0ca223e50ce149b1944393f7b.zip
kernel: update 3.10 to 3.10.3
Also refresh 3.10 patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37546 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros')
-rw-r--r--target/linux/atheros/patches-3.10/001-get_c0_compare_int_fix.patch2
-rw-r--r--target/linux/atheros/patches-3.10/100-board.patch4
-rw-r--r--target/linux/atheros/patches-3.10/101-early-printk-support.patch2
-rw-r--r--target/linux/atheros/patches-3.10/120-spiflash.patch2
-rw-r--r--target/linux/atheros/patches-3.10/130-watchdog.patch4
-rw-r--r--target/linux/atheros/patches-3.10/230-3_10-updates.patch2
6 files changed, 7 insertions, 9 deletions
diff --git a/target/linux/atheros/patches-3.10/001-get_c0_compare_int_fix.patch b/target/linux/atheros/patches-3.10/001-get_c0_compare_int_fix.patch
index ff6cc998ff..d0907733cb 100644
--- a/target/linux/atheros/patches-3.10/001-get_c0_compare_int_fix.patch
+++ b/target/linux/atheros/patches-3.10/001-get_c0_compare_int_fix.patch
@@ -6,7 +6,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
--- a/arch/mips/kernel/cevt-r4k.c
+++ b/arch/mips/kernel/cevt-r4k.c
-@@ -173,20 +173,23 @@ int __cpuinit r4k_clockevent_init(void)
+@@ -177,20 +177,23 @@ int __cpuinit r4k_clockevent_init(void)
struct clock_event_device *cd;
unsigned int irq;
diff --git a/target/linux/atheros/patches-3.10/100-board.patch b/target/linux/atheros/patches-3.10/100-board.patch
index 8663156ade..efbb811a08 100644
--- a/target/linux/atheros/patches-3.10/100-board.patch
+++ b/target/linux/atheros/patches-3.10/100-board.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -135,6 +135,19 @@ config BCM63XX
+@@ -137,6 +137,19 @@ config BCM63XX
help
Support for BCM63XX based boards
@@ -20,7 +20,7 @@
config MIPS_COBALT
bool "Cobalt Server"
select CEVT_R4K
-@@ -836,6 +849,7 @@ config NLM_XLP_BOARD
+@@ -837,6 +850,7 @@ config NLM_XLP_BOARD
endchoice
diff --git a/target/linux/atheros/patches-3.10/101-early-printk-support.patch b/target/linux/atheros/patches-3.10/101-early-printk-support.patch
index 7b0b2ec4de..dc5f3a8dc8 100644
--- a/target/linux/atheros/patches-3.10/101-early-printk-support.patch
+++ b/target/linux/atheros/patches-3.10/101-early-printk-support.patch
@@ -58,7 +58,7 @@
obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -145,6 +145,7 @@ config ATHEROS_AR231X
+@@ -147,6 +147,7 @@ config ATHEROS_AR231X
select SYS_SUPPORTS_BIG_ENDIAN
select SYS_SUPPORTS_32BIT_KERNEL
select ARCH_REQUIRE_GPIOLIB
diff --git a/target/linux/atheros/patches-3.10/120-spiflash.patch b/target/linux/atheros/patches-3.10/120-spiflash.patch
index 6be5705483..ef9cb91622 100644
--- a/target/linux/atheros/patches-3.10/120-spiflash.patch
+++ b/target/linux/atheros/patches-3.10/120-spiflash.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/Kconfig
+++ b/drivers/mtd/devices/Kconfig
-@@ -136,6 +136,10 @@ config MTD_BCM47XXSFLASH
+@@ -135,6 +135,10 @@ config MTD_BCM47XXSFLASH
registered by bcma as platform devices. This enables driver for
serial flash memories (only read-only mode is implemented).
diff --git a/target/linux/atheros/patches-3.10/130-watchdog.patch b/target/linux/atheros/patches-3.10/130-watchdog.patch
index 085f31547a..190c144996 100644
--- a/target/linux/atheros/patches-3.10/130-watchdog.patch
+++ b/target/linux/atheros/patches-3.10/130-watchdog.patch
@@ -202,7 +202,7 @@
+module_exit(exit_ar2315_wdt);
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
-@@ -1077,6 +1077,12 @@ config LANTIQ_WDT
+@@ -1104,6 +1104,12 @@ config LANTIQ_WDT
help
Hardware driver for the Lantiq SoC Watchdog Timer.
@@ -217,7 +217,7 @@
# POWERPC Architecture
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
-@@ -128,6 +128,7 @@ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
+@@ -130,6 +130,7 @@ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt.o
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
diff --git a/target/linux/atheros/patches-3.10/230-3_10-updates.patch b/target/linux/atheros/patches-3.10/230-3_10-updates.patch
index 73461eaf1c..8428128039 100644
--- a/target/linux/atheros/patches-3.10/230-3_10-updates.patch
+++ b/target/linux/atheros/patches-3.10/230-3_10-updates.patch
@@ -20,8 +20,6 @@
}
---- a/drivers/net/phy/mvswitch.c
-+++ b/drivers/net/phy/mvswitch.c
@@ -307,9 +307,9 @@ mvswitch_config_init(struct phy_device *
#ifdef HEADER_MODE