aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-2.6.26/130-ar2313_ethernet.patch
diff options
context:
space:
mode:
authorMatteo Croce <matteo@openwrt.org>2008-07-27 21:42:36 +0000
committerMatteo Croce <matteo@openwrt.org>2008-07-27 21:42:36 +0000
commitbc7f26dd5e4b49cc4b3e64de11cb0b1c27a67983 (patch)
treed02bf3287c556cb6661a36c58998a71522e408e0 /target/linux/atheros/patches-2.6.26/130-ar2313_ethernet.patch
parent46a156a79464da6d0b3e1f43605b7ff5625570df (diff)
downloadmaster-187ad058-bc7f26dd5e4b49cc4b3e64de11cb0b1c27a67983.tar.gz
master-187ad058-bc7f26dd5e4b49cc4b3e64de11cb0b1c27a67983.tar.bz2
master-187ad058-bc7f26dd5e4b49cc4b3e64de11cb0b1c27a67983.zip
atheros: 2.6.26 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11965 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros/patches-2.6.26/130-ar2313_ethernet.patch')
-rw-r--r--target/linux/atheros/patches-2.6.26/130-ar2313_ethernet.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/atheros/patches-2.6.26/130-ar2313_ethernet.patch b/target/linux/atheros/patches-2.6.26/130-ar2313_ethernet.patch
new file mode 100644
index 0000000000..13580d1801
--- /dev/null
+++ b/target/linux/atheros/patches-2.6.26/130-ar2313_ethernet.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -367,6 +367,12 @@
+ help
+ Select this if your platform comes with an external 93CX6 eeprom.
+
++config AR2313
++ tristate "AR2313 Ethernet support"
++ depends on NET_ETHERNET && ATHEROS
++ help
++ Support for the AR231x/531x ethernet controller
++
+ config MACE
+ tristate "MACE (Power Mac ethernet) support"
+ depends on PPC_PMAC && PPC32
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -194,6 +194,7 @@
+ obj-$(CONFIG_KORINA) += korina.o
+ obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
+ obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
++obj-$(CONFIG_AR2313) += ar2313/
+ obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
+ obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
+ obj-$(CONFIG_DECLANCE) += declance.o