aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commit6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e (patch)
tree30cacdb892969714d2a079f391ba6786b7c36489 /target/linux/atheros/Makefile
parent9647361f814667b536160d416666bd25ab4b82fa (diff)
downloadmaster-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.gz
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.bz2
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8694 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/atheros/Makefile')
-rw-r--r--target/linux/atheros/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index 611345f4bb..fc48efd5de 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -13,14 +13,15 @@ FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.22.4
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-madwifi
+
define Target/Description
Build firmware images for Atheros SoC boards
endef
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-madwifi
-
# include the profiles
-include profiles/*.mk
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))