aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/profiles
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2016-06-22 22:48:28 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-22 22:48:28 +0200
commitc87080ee05157d2f3749bb92c5eda804037c4f15 (patch)
treea9cd4da2e1570daa8af2f15206b3b2a6a65bbe5e /target/linux/ath25/profiles
parent3b4425c874c036370e97bf19a571539fa1b0f354 (diff)
downloadmaster-187ad058-c87080ee05157d2f3749bb92c5eda804037c4f15.tar.gz
master-187ad058-c87080ee05157d2f3749bb92c5eda804037c4f15.tar.bz2
master-187ad058-c87080ee05157d2f3749bb92c5eda804037c4f15.zip
ath25: update kernel from 3.18 to 4.4
Summary of changes: * moved config-3.18 to config-4.4 and patches-3.18 to patches-4.4 * removed most of the first two patches, that seem to be upstream already * changed deprecated/removed IRQF_DISABLED to zero following examples in upstream kernel patches * added config line to disable device-tree to satisfy kernel configuration * add new image generation code Build tested and run tested on an Accton MR3201A. Signed-off-by: Russell Senior <russell@personaltelco.net> Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ath25/profiles')
-rw-r--r--target/linux/ath25/profiles/00-default.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath25/profiles/00-default.mk b/target/linux/ath25/profiles/00-default.mk
new file mode 100644
index 0000000000..b40eb1b0ce
--- /dev/null
+++ b/target/linux/ath25/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))