aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-13 19:45:31 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-13 19:45:31 +0000
commite4689a3dbe5daaab6019671cd9b50142d121f46f (patch)
treece193b7d5dc2364658e3a0cfbe26d311ea0c0ade /target/linux/at91
parentab41ed7d558bbbe2f91b2c6ba248d4895032136e (diff)
downloadmaster-187ad058-e4689a3dbe5daaab6019671cd9b50142d121f46f.tar.gz
master-187ad058-e4689a3dbe5daaab6019671cd9b50142d121f46f.tar.bz2
master-187ad058-e4689a3dbe5daaab6019671cd9b50142d121f46f.zip
at91: fix at91-adc dependencies
Error reported by buildbot: Package kmod-at91-adc is missing dependencies for the following libraries: input-core.ko only compile tested Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42893 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
index 4678b92646..7f98233eb5 100644
--- a/target/linux/at91/modules.mk
+++ b/target/linux/at91/modules.mk
@@ -38,7 +38,7 @@ $(eval $(call KernelPackage,pwm-atmel))
define KernelPackage/at91-adc
SUBMENU:=$(OTHER_MENU)
TITLE:=ADC on atmel SoC
- DEPENDS:=@TARGET_at91 +kmod-iio-core
+ DEPENDS:=@TARGET_at91 +kmod-iio-core +kmod-input-core
KCONFIG:=CONFIG_AT91_ADC
FILES:=$(LINUX_DIR)/drivers/iio/adc/at91_adc.ko
AUTOLOAD:=$(call AutoLoad,40,at91_adc)