aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-01-19 10:15:14 +0000
committerJohn Crispin <blogic@openwrt.org>2016-01-19 10:15:14 +0000
commitc9422c205b1bfc79ad064c1ddb165cb69304d58b (patch)
tree3c47bef823bb422c0d702bf758a1fae6e2b1ef18 /target/linux/at91
parent09ef2d9f2a2ed5a5d475b9430cf21b1fea9500a9 (diff)
downloadmaster-187ad058-c9422c205b1bfc79ad064c1ddb165cb69304d58b.tar.gz
master-187ad058-c9422c205b1bfc79ad064c1ddb165cb69304d58b.tar.bz2
master-187ad058-c9422c205b1bfc79ad064c1ddb165cb69304d58b.zip
at91: add package for high speed usb device
Add a package for a missing module for the at91 high speed device. Without this the build process pauses asking to build as module. Signed-off-by: Ben Whitten <ben.whitten@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48350 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/modules.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
index 6cfc3e4074..3969450e8d 100644
--- a/target/linux/at91/modules.mk
+++ b/target/linux/at91/modules.mk
@@ -69,6 +69,25 @@ endef
$(eval $(call KernelPackage,at91-udc))
+define KernelPackage/atmel-usba-udc
+ SUBMENU:=$(USB_MENU)
+ TITLE:=High-speed USB Device Controller on atmel SoC
+ DEPENDS:=@TARGET_at91 +kmod-usb-gadget
+ KCONFIG:=CONFIG_USB_ATMEL_USBA
+ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/gadget/udc/atmel_usba_udc.ko),)
+ FILES:=$(LINUX_DIR)/drivers/usb/gadget/udc/atmel_usba_udc.ko
+else
+ FILES:=$(LINUX_DIR)/drivers/usb/gadget/atmel_usba_udc.ko
+endif
+ AUTOLOAD:=$(call AutoLoad,51,atmel_usba_udc)
+endef
+
+define KernelPackage/atmel-usba-udc/description
+ Kernel module to use the High-speed USB Device controller for Atmel AT91
+endef
+
+$(eval $(call KernelPackage,atmel-usba-udc))
+
I2C_AT91_MODULES:=\
CONFIG_I2C_AT91:drivers/i2c/busses/i2c-at91