aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-28 13:25:21 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-28 13:25:21 +0000
commit939fca84540a7d2580b6e475f364bb9bd1230f85 (patch)
tree03d23a1e932c0f386f6b3f16fa42a48613b0e0e6 /target/linux/at91
parentb26611b1c792e30de83561541143f9a256d41a8c (diff)
downloadmaster-187ad058-939fca84540a7d2580b6e475f364bb9bd1230f85.tar.gz
master-187ad058-939fca84540a7d2580b6e475f364bb9bd1230f85.tar.bz2
master-187ad058-939fca84540a7d2580b6e475f364bb9bd1230f85.zip
at91: fix imagebuilder
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45806 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 49e2bee5c1..4e472f23db 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -24,6 +24,7 @@ define Build/Compile
endef
define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/Image $(KDIR)/Image
cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
endef
@@ -89,9 +90,9 @@ endef
define Image/BuildKernel
mkimage -A arm -T kernel -C none -a 0x20008000 -e 0x20008000 -n linux-2.6 \
- -d $(LINUX_DIR)/arch/arm/boot/Image $(BIN_DIR)/uImage
+ -d $(KDIR)/Image $(BIN_DIR)/$(IMG_PREFIX)-uImage
if [ $(CONFIG_FLEXIBITY_ROOT) ]; then \
- $(INSTALL_BIN) $(BIN_DIR)/uImage $(TARGET_DIR)/uImage ; \
+ $(INSTALL_BIN) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/uImage ; \
fi
$(call Image/Build/Kernel/$(PROFILE))
endef