aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
commit9157f620436a8383b13c30c0a26ad06b976b1a0b (patch)
tree768c585c31df15ffc89cd03480ce4558ea291ca0 /target/linux/at91
parent19deb0cf132ecd6cd1b4aa79fcc4462c698a38dd (diff)
downloadmaster-187ad058-9157f620436a8383b13c30c0a26ad06b976b1a0b.tar.gz
master-187ad058-9157f620436a8383b13c30c0a26ad06b976b1a0b.tar.bz2
master-187ad058-9157f620436a8383b13c30c0a26ad06b976b1a0b.zip
kernel: update 3.18 to 3.18.14
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45711 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/patches/101-ARM-at91-build-dtb-for-q5xr5.patch2
-rw-r--r--target/linux/at91/patches/200-ARM-at91-udc-clockfix-backport.patch10
-rw-r--r--target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch2
3 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/at91/patches/101-ARM-at91-build-dtb-for-q5xr5.patch b/target/linux/at91/patches/101-ARM-at91-build-dtb-for-q5xr5.patch
index 0465552c1b..b5a9b68f3d 100644
--- a/target/linux/at91/patches/101-ARM-at91-build-dtb-for-q5xr5.patch
+++ b/target/linux/at91/patches/101-ARM-at91-build-dtb-for-q5xr5.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -20,6 +20,7 @@
+@@ -20,6 +20,7 @@ dtb-$(CONFIG_ARCH_AT91) += tny_a9263.dtb
dtb-$(CONFIG_ARCH_AT91) += usb_a9263.dtb
# sam9g20
dtb-$(CONFIG_ARCH_AT91) += at91-foxg20.dtb
diff --git a/target/linux/at91/patches/200-ARM-at91-udc-clockfix-backport.patch b/target/linux/at91/patches/200-ARM-at91-udc-clockfix-backport.patch
index 1aec3d00b8..32e1ac540d 100644
--- a/target/linux/at91/patches/200-ARM-at91-udc-clockfix-backport.patch
+++ b/target/linux/at91/patches/200-ARM-at91-udc-clockfix-backport.patch
@@ -1,6 +1,6 @@
--- a/drivers/usb/gadget/udc/at91_udc.c
+++ b/drivers/usb/gadget/udc/at91_udc.c
-@@ -870,8 +870,6 @@
+@@ -870,8 +870,6 @@ static void clk_on(struct at91_udc *udc)
return;
udc->clocked = 1;
@@ -9,7 +9,7 @@
clk_enable(udc->iclk);
clk_enable(udc->fclk);
}
-@@ -884,8 +882,6 @@
+@@ -884,8 +882,6 @@ static void clk_off(struct at91_udc *udc
udc->gadget.speed = USB_SPEED_UNKNOWN;
clk_disable(udc->fclk);
clk_disable(udc->iclk);
@@ -18,7 +18,7 @@
}
/*
-@@ -1766,27 +1762,18 @@
+@@ -1766,27 +1762,18 @@ static int at91udc_probe(struct platform
udc_reinit(udc);
/* get interface and function clocks */
@@ -51,7 +51,7 @@
retval = clk_prepare_enable(udc->iclk);
if (retval)
-@@ -1860,12 +1847,7 @@
+@@ -1860,12 +1847,7 @@ fail1c:
clk_unprepare(udc->iclk);
fail1b:
clk_unprepare(udc->fclk);
@@ -64,7 +64,7 @@
if (!IS_ERR(udc->fclk))
clk_put(udc->fclk);
if (!IS_ERR(udc->iclk))
-@@ -1911,15 +1893,11 @@
+@@ -1911,15 +1893,11 @@ static int __exit at91udc_remove(struct
res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
release_mem_region(res->start, resource_size(res));
diff --git a/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
index a97850ac91..1da2e4d4f4 100644
--- a/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
+++ b/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/mach-at91/board-flexibity.c
+++ b/arch/arm/mach-at91/board-flexibity.c
-@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
+@@ -90,49 +90,49 @@ static struct gpio_led flexibity_leds[]
.name = "usb1:green",
.gpio = AT91_PIN_PA12,
.active_low = 1,