aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-07-28 20:47:08 +0000
committerJohn Crispin <blogic@openwrt.org>2012-07-28 20:47:08 +0000
commit841bbe2dbd9e7b838351898c3494c06b44a55b6e (patch)
tree13ea7bdfdd6e40937e1b52e56a66ba84d26b1cf7 /target/linux/at91
parent388d1df96152148e5d6812963f8195dc7391ef86 (diff)
downloadmaster-187ad058-841bbe2dbd9e7b838351898c3494c06b44a55b6e.tar.gz
master-187ad058-841bbe2dbd9e7b838351898c3494c06b44a55b6e.tar.bz2
master-187ad058-841bbe2dbd9e7b838351898c3494c06b44a55b6e.zip
[kernel] clean up pwm patches and drivers
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32901 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/modules.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
index 0c6c03ab59..9c8ef3d5a8 100644
--- a/target/linux/at91/modules.mk
+++ b/target/linux/at91/modules.mk
@@ -24,10 +24,9 @@ define KernelPackage/pwm-atmel
SUBMENU:=$(OTHER_MENU)
TITLE:=PWM on atmel SoC
DEPENDS:=@TARGET_at91
- KCONFIG:=CONFIG_GENERIC_PWM \
- CONFIG_ATMEL_PWM
- FILES:=$(LINUX_DIR)/drivers/pwm/atmel-pwm.ko
- AUTOLOAD:=$(call AutoLoad,51,atmel-pwm)
+ KCONFIG:=CONFIG_ATMEL_PWM
+ FILES:=$(LINUX_DIR)/drivers/misc/atmel_pwm.ko
+ AUTOLOAD:=$(call AutoLoad,51,atmel_pwm)
endef
define KernelPackage/pwm-atmel/description