aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches-3.14
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-18 13:35:46 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-18 13:35:46 +0000
commitb77e03c4bf8e89f4b1f5bc7d3b9f478b67162e10 (patch)
treef05495d6a9adf4b3e15e1fc0a173e98b25b4f700 /target/linux/at91/patches-3.14
parente51055dc1dfc3426ac608ce8cd02a9fabb6a5ec1 (diff)
downloadmaster-187ad058-b77e03c4bf8e89f4b1f5bc7d3b9f478b67162e10.tar.gz
master-187ad058-b77e03c4bf8e89f4b1f5bc7d3b9f478b67162e10.tar.bz2
master-187ad058-b77e03c4bf8e89f4b1f5bc7d3b9f478b67162e10.zip
at91: bump to v3.18
Signed-off-by: Your Name <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44489 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91/patches-3.14')
-rw-r--r--target/linux/at91/patches-3.14/100-ARM-at91-build-dtb-for-LMU5000.patch10
-rw-r--r--target/linux/at91/patches-3.14/805-free_some_portc_pins.patch11
-rw-r--r--target/linux/at91/patches-3.14/901-AT91-flexibity-default-leds-to-heartbeat.patch60
3 files changed, 0 insertions, 81 deletions
diff --git a/target/linux/at91/patches-3.14/100-ARM-at91-build-dtb-for-LMU5000.patch b/target/linux/at91/patches-3.14/100-ARM-at91-build-dtb-for-LMU5000.patch
deleted file mode 100644
index e8cc68d13d..0000000000
--- a/target/linux/at91/patches-3.14/100-ARM-at91-build-dtb-for-LMU5000.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -26,6 +26,7 @@ dtb-$(CONFIG_ARCH_AT91) += usb_a9g20.dtb
- dtb-$(CONFIG_ARCH_AT91) += usb_a9g20_lpw.dtb
- # sam9g45
- dtb-$(CONFIG_ARCH_AT91) += at91sam9m10g45ek.dtb
-+dtb-$(CONFIG_ARCH_AT91) += lmu5000.dtb
- dtb-$(CONFIG_ARCH_AT91) += pm9g45.dtb
- # sam9n12
- dtb-$(CONFIG_ARCH_AT91) += at91sam9n12ek.dtb
diff --git a/target/linux/at91/patches-3.14/805-free_some_portc_pins.patch b/target/linux/at91/patches-3.14/805-free_some_portc_pins.patch
deleted file mode 100644
index a9694d1f01..0000000000
--- a/target/linux/at91/patches-3.14/805-free_some_portc_pins.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/arm/mach-at91/at91sam9260_devices.c
-+++ b/arch/arm/mach-at91/at91sam9260_devices.c
-@@ -507,7 +507,7 @@ static struct platform_device at91sam926
- .num_resources = ARRAY_SIZE(spi1_resources),
- };
-
--static const unsigned spi1_standard_cs[4] = { AT91_PIN_PB3, AT91_PIN_PC5, AT91_PIN_PC4, AT91_PIN_PC3 };
-+static const unsigned spi1_standard_cs[2] = { AT91_PIN_PB3, AT91_PIN_PC5 };
-
- void __init at91_add_device_spi(struct spi_board_info *devices, int nr_devices)
- {
diff --git a/target/linux/at91/patches-3.14/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches-3.14/901-AT91-flexibity-default-leds-to-heartbeat.patch
deleted file mode 100644
index a97850ac91..0000000000
--- a/target/linux/at91/patches-3.14/901-AT91-flexibity-default-leds-to-heartbeat.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/arch/arm/mach-at91/board-flexibity.c
-+++ b/arch/arm/mach-at91/board-flexibity.c
-@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
- .name = "usb1:green",
- .gpio = AT91_PIN_PA12,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb1:red",
- .gpio = AT91_PIN_PA13,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb2:green",
- .gpio = AT91_PIN_PB26,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb2:red",
- .gpio = AT91_PIN_PB27,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb3:green",
- .gpio = AT91_PIN_PC8,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb3:red",
- .gpio = AT91_PIN_PC6,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb4:green",
- .gpio = AT91_PIN_PB4,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- },
- {
- .name = "usb4:red",
- .gpio = AT91_PIN_PB5,
- .active_low = 1,
-- .default_trigger = "default-on",
-+ .default_trigger = "heartbeat",
- }
- };
-