aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/u-boot/Makefile
diff options
context:
space:
mode:
authorClaudio Mignanti <c.mignanti@gmail.com>2010-07-22 11:32:38 +0000
committerClaudio Mignanti <c.mignanti@gmail.com>2010-07-22 11:32:38 +0000
commit2eb7eb9b04a2dd1edeac24c789c4f56d09a43e20 (patch)
tree6ea565c499d74056cbe4cdf8ddf94626a0f31d47 /target/linux/at91/image/u-boot/Makefile
parentc65d6372b537a9d870308e3375c17ff96dad488e (diff)
downloadmaster-187ad058-2eb7eb9b04a2dd1edeac24c789c4f56d09a43e20.tar.gz
master-187ad058-2eb7eb9b04a2dd1edeac24c789c4f56d09a43e20.tar.bz2
master-187ad058-2eb7eb9b04a2dd1edeac24c789c4f56d09a43e20.zip
[at91] Add support for u-boot
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22351 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91/image/u-boot/Makefile')
-rw-r--r--target/linux/at91/image/u-boot/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/target/linux/at91/image/u-boot/Makefile b/target/linux/at91/image/u-boot/Makefile
index 89a2be0494..1d1b31455a 100644
--- a/target/linux/at91/image/u-boot/Makefile
+++ b/target/linux/at91/image/u-boot/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=u-boot
-PKG_VERSION:=1.1.4
+PKG_VERSION:=2010.06
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -34,16 +34,18 @@ define Build/Compile
$(CP) ./ubclient/* $(PKG_BUILD_DIR)/ubclient
export LAN_IP=$(LAN_IP); \
export LAN_SERVERIP=$(LAN_SERVERIP); \
- $(MAKE) -C $(PKG_BUILD_DIR)/ubclient \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(BOARD)=1"
+ #$(MAKE) -C $(PKG_BUILD_DIR)/ubclient \
+ # $(TARGET_CONFIGURE_OPTS) \
+ # CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(BOARD)=1"
endef
define Build/InstallDev
dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(PKG_BUILD_DIR)/u-boot.block bs=232k count=1 conv=sync
# $(INSTALL_DIR) $(STAGING_DIR)/ubclient/sbin
# $(INSTALL_BIN) $(PKG_BUILD_DIR)/ubclient/ubpar $(STAGING_DIR)/ubclient/sbin/
- $(CP) $(PKG_BUILD_DIR)/ubclient/ubpar ../../base-files/sbin
+# $(CP) $(PKG_BUILD_DIR)/ubclient/ubpar ../../base-files/sbin
+ mkdir -p $(BIN_DIR)/
+ cp $(PKG_BUILD_DIR)/u-boot.bin $(BIN_DIR)/u-boot.$(PKG_VERSION).bin
endef
$(eval $(call Build/DefaultTargets))