aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/Makefile
diff options
context:
space:
mode:
authorClaudio Mignanti <c.mignanti@gmail.com>2010-06-18 22:12:33 +0000
committerClaudio Mignanti <c.mignanti@gmail.com>2010-06-18 22:12:33 +0000
commitf51df41a3aba2bf2d93c12fbbae9c9241c400fd2 (patch)
tree76cb293761a2d53938d2f6462e6ce010bdf2691a /target/linux/at91/Makefile
parenta069981ab9d28e823d427627297dcd7e79940b5b (diff)
downloadmaster-187ad058-f51df41a3aba2bf2d93c12fbbae9c9241c400fd2.tar.gz
master-187ad058-f51df41a3aba2bf2d93c12fbbae9c9241c400fd2.tar.bz2
master-187ad058-f51df41a3aba2bf2d93c12fbbae9c9241c400fd2.zip
[at91] revamp target: add support for netusg20 board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21838 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91/Makefile')
-rw-r--r--target/linux/at91/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index 70a6082623..2f86b311d0 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,17 +8,19 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=at91
-BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb broken
+BOARDNAME:=NetusG20
+FEATURES:=squashfs jffs2 tgz
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
-LINUX_VERSION:=2.6.25.20
+LINUX_VERSION:=2.6.34
+DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk
KERNELNAME:="uImage"
define Target/Description
- Build fimware images for Figment Design Labs VersaLink board.
+ Build firmware images for Acmesystems NetusG20 board
endef
$(eval $(call BuildTarget))