aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/image/u-boot/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-06-14 13:46:24 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-06-14 13:46:24 +0000
commit0739e214021346a6c6d15874d0c9ce673f9027eb (patch)
treee3d8fb36def3a6374a2c0c443e65bde6ec6b9209 /target/linux/at91-2.6/image/u-boot/Makefile
parentfc49e61382e2d6a89c740a4315df015ed21ed32d (diff)
downloadmaster-187ad058-0739e214021346a6c6d15874d0c9ce673f9027eb.tar.gz
master-187ad058-0739e214021346a6c6d15874d0c9ce673f9027eb.tar.bz2
master-187ad058-0739e214021346a6c6d15874d0c9ce673f9027eb.zip
Added config parameters for u-boot client IP address as well as TFTP
server IP address. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7632 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91-2.6/image/u-boot/Makefile')
-rw-r--r--target/linux/at91-2.6/image/u-boot/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/at91-2.6/image/u-boot/Makefile b/target/linux/at91-2.6/image/u-boot/Makefile
index 35b1e9bff1..6fd667de12 100644
--- a/target/linux/at91-2.6/image/u-boot/Makefile
+++ b/target/linux/at91-2.6/image/u-boot/Makefile
@@ -22,13 +22,19 @@ PKG_CAT:=bzcat
include $(INCLUDE_DIR)/package.mk
UBOOT_CONFIG=$(strip $(subst ",, $(CONFIG_UBOOT_TARGET)))
+LAN_IP=$(strip $(CONFIG_UBOOT_IPADDR))
+LAN_SERVERIP=$(strip $(subst ",, $(CONFIG_UBOOT_SERVERIP)))
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
export CROSS_COMPILE=$(TARGET_CROSS); \
+ export LAN_IP=$(LAN_IP); \
+ export LAN_SERVERIP=$(LAN_SERVERIP); \
$(MAKE) -C $(PKG_BUILD_DIR)
mkdir -p $(PKG_BUILD_DIR)/ubclient
$(CP) ./ubclient/* $(PKG_BUILD_DIR)/ubclient
+ export LAN_IP=$(LAN_IP); \
+ export LAN_SERVERIP=$(LAN_SERVERIP); \
$(MAKE) -C $(PKG_BUILD_DIR)/ubclient \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(BOARD)=1"