aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/image/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-03-20 09:59:17 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-03-20 09:59:17 +0000
commitce65b07441aa8bd6efb9908991b1b50cdf8d9781 (patch)
tree18df426a0f5674776b7ad0d177c8abf178812f58 /target/linux/at91-2.6/image/Makefile
parent0dc6f05b1c4a1e40d1a021ed46aeaac256c70ecc (diff)
downloadmaster-187ad058-ce65b07441aa8bd6efb9908991b1b50cdf8d9781.tar.gz
master-187ad058-ce65b07441aa8bd6efb9908991b1b50cdf8d9781.tar.bz2
master-187ad058-ce65b07441aa8bd6efb9908991b1b50cdf8d9781.zip
Added primary and secondary bootloaders
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6626 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91-2.6/image/Makefile')
-rw-r--r--target/linux/at91-2.6/image/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/target/linux/at91-2.6/image/Makefile b/target/linux/at91-2.6/image/Makefile
index 07660f2350..8b1a9476d7 100644
--- a/target/linux/at91-2.6/image/Makefile
+++ b/target/linux/at91-2.6/image/Makefile
@@ -5,16 +5,25 @@
# See /LICENSE for more information.
#
-TARGET_DEVICE_TABLE:=$(TOPDIR)/target/linux/vlink-2.6/image/device_table.txt
-
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Build/Clean
+ $(MAKE) -C romboot clean
+ $(MAKE) -C u-boot clean
+endef
+
+define Build/Compile
+ $(MAKE) -C romboot compile
+# $(MAKE) -C u-boot configure
+ $(MAKE) -C u-boot compile
endef
define Image/Prepare
cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+ cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
+ cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
+ cat $(KDIR)/romboot/romboot.block $(KDIR)/u-boot-1.1.4/u-boot.block > $(KDIR)/loaders.block
endef
define Image/BuildKernel
@@ -25,12 +34,4 @@ define Image/Build
$(call Image/Build/$(1),$(1))
endef
-define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
-endef
-
-define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
-endef
-
$(eval $(call BuildImage))