aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/arm64/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-11-24 06:34:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-11-24 06:34:07 +0000
commitbc2ddd55171ec84fa46f41c2734f7a8a87a64156 (patch)
tree4a1104aa0d8e42b5147c3280f3ed240e8fcbb060 /target/linux/arm64/Makefile
parent41a786620a2fc5b8b60b2edeed3d643ecf3fa70b (diff)
downloadmaster-187ad058-bc2ddd55171ec84fa46f41c2734f7a8a87a64156.tar.gz
master-187ad058-bc2ddd55171ec84fa46f41c2734f7a8a87a64156.tar.bz2
master-187ad058-bc2ddd55171ec84fa46f41c2734f7a8a87a64156.zip
arm64: add ARM 64-bits target
This target can be emulated using ARM's Foundation_V8 simulator software or qemu-system-aarch64 using the command-line described in the README file. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43355 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/arm64/Makefile')
-rw-r--r--target/linux/arm64/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/arm64/Makefile b/target/linux/arm64/Makefile
new file mode 100644
index 0000000000..a30430bb70
--- /dev/null
+++ b/target/linux/arm64/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=aarch64
+BOARD:=arm64
+BOARDNAME:=ARMv8 multiplatform
+FEATURES:=fpu ramdisk
+CFLAGS:=-Os -pipe -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+KERNEL_PATCHVER:=3.14
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build multi-platform images for the ARMv8 instruction set architecture
+endef
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))