aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/archs38/generic/profiles/01-minimal.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-18 08:22:32 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-18 08:22:32 +0000
commit2b12dc6530da8d4045af0c81dff67b022e9718ae (patch)
treec84318ce5e3a10a11a7b5cd117f612c5c86b3553 /target/linux/archs38/generic/profiles/01-minimal.mk
parentd698d2584beff7860f1784873d1e97038620528a (diff)
downloadmaster-187ad058-2b12dc6530da8d4045af0c81dff67b022e9718ae.tar.gz
master-187ad058-2b12dc6530da8d4045af0c81dff67b022e9718ae.tar.bz2
master-187ad058-2b12dc6530da8d4045af0c81dff67b022e9718ae.zip
linux: add support of Synopsys ARCHS38-based boards
This patch introduces support of new boards with ARC HS38 cores. ARC HS38 is a new generation of ARC cores which utilize ARCv2 ISA. As with ARC770 we're addind support for 2 boards for now: [1] Synopsys SDP board (AXS103) This is the same base-board as in AXS101 but with FPGA-based CPU-tile where ARCHs38 core is implemented. [2] nSIM Again this is the same simulation engine but configured for new instruction set and features of new CPU. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48740 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/archs38/generic/profiles/01-minimal.mk')
-rw-r--r--target/linux/archs38/generic/profiles/01-minimal.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/archs38/generic/profiles/01-minimal.mk b/target/linux/archs38/generic/profiles/01-minimal.mk
new file mode 100644
index 0000000000..fe8d8c3a59
--- /dev/null
+++ b/target/linux/archs38/generic/profiles/01-minimal.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Minimal
+ NAME:=Minimal Profile (no drivers)
+endef
+
+define Profile/Minimal/Description
+ Minimal package set compatible with most boards.
+endef
+$(eval $(call Profile,Minimal))