aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/arc770/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-22 19:06:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-22 19:06:07 +0000
commita8b74d20696c2b789d5946114f658842e357fb42 (patch)
tree7ddf82769a54ae1468f7577fae9c539dd586f023 /target/linux/arc770/image
parent2ff8f4600c7574c5a17fa6fa40e68aaf5f594b3d (diff)
downloadmaster-187ad058-a8b74d20696c2b789d5946114f658842e357fb42.tar.gz
master-187ad058-a8b74d20696c2b789d5946114f658842e357fb42.tar.bz2
master-187ad058-a8b74d20696c2b789d5946114f658842e357fb42.zip
linux: add support of Synopsys ARC770-based boards
This patch introduces support of new boards with ARC cores. [1] Synopsys SDP board This is a new-generation development board from Synopsys that consists of base-board and CPU tile-board (which might have a real ASIC or FPGA with CPU image). It sports a lot of DesignWare peripherals like GMAC, USB, SPI, I2C etc and is intended to be used for early development of ARC-based products. [2] nSIM This is a virtual board implemented in Synopsys proprietary software simulator (even though available for free for open source community). This board has only serial port as a peripheral and so it is meant to be used for runtime testing which is especially useful during bring-up of new tools and platforms. What's also important ARC cores are very configurable so there're many variations of options like cache sizes, their line lengths, additional hardware blocks like multipliers, dividers etc. And this board could be used to make sure built software still runs on different HW configurations. Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47589 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/arc770/image')
-rw-r--r--target/linux/arc770/image/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/arc770/image/Makefile b/target/linux/arc770/image/Makefile
new file mode 100644
index 0000000000..c033102d51
--- /dev/null
+++ b/target/linux/arc770/image/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/patch-dtb
+ $(call Image/BuildDTB,../dts/$(DEVICE_DTS).dts,$@.dtb)
+ $(STAGING_DIR_HOST)/bin/patch-dtb $@ $@.dtb
+endef
+
+# Shared device definition: applies to every defined device
+define Device/Default
+ PROFILES = Default $$(DEVICE_PROFILE)
+ KERNEL_SUFFIX := .elf
+ KERNEL_INITRAMFS := kernel-bin | patch-dtb
+ KERNEL_INITRAMFS_NAME = $$(KERNEL_NAME)-initramfs.elf
+ DEVICE_PROFILE :=
+ DEVICE_DTS :=
+endef
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
+
+define add_arc770
+ define Device/$(1)
+ DEVICE_PROFILE := $(1)
+ DEVICE_DTS := $(1)
+ endef
+ TARGET_DEVICES += $(1)
+endef
+
+# DesignWare AXS101
+$(eval $(call add_arc770,axs101))
+
+# nSIM with ARC770
+$(eval $(call add_arc770,nsim_700))
+
+$(eval $(call BuildImage))