aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-05 17:32:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-05 17:32:36 +0000
commit2034dd105a5d0cfc371fb00eb7bfbfced18fb748 (patch)
tree1856884eed9a05ba21142f46b8a2ac6a7548de1a /target/linux/ar7
parentaafbc3e734ab094770ad7364eec69d02a3a9b0c6 (diff)
downloadmaster-187ad058-2034dd105a5d0cfc371fb00eb7bfbfced18fb748.tar.gz
master-187ad058-2034dd105a5d0cfc371fb00eb7bfbfced18fb748.tar.bz2
master-187ad058-2034dd105a5d0cfc371fb00eb7bfbfced18fb748.zip
ar7: fix kernel_entry extraction
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31614 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7')
-rw-r--r--target/linux/ar7/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar7/image/Makefile b/target/linux/ar7/image/Makefile
index 2d8ef64271..d27c2e8888 100644
--- a/target/linux/ar7/image/Makefile
+++ b/target/linux/ar7/image/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -75,9 +75,9 @@ endef
#endef
define Image/Build/EVA
- $(STAGING_DIR_HOST)/bin/lzma2eva $(EVA_LOADADDR) 0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep kernel_entry | cut -d' ' -f1} $(KDIR)/vmlinux.lzma $(KDIR)/loader.eva
+ $(STAGING_DIR_HOST)/bin/lzma2eva $(EVA_LOADADDR) 0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep -w kernel_entry | cut -d' ' -f1} $(KDIR)/vmlinux.lzma $(KDIR)/loader.eva
dd if=$(KDIR)/loader.eva $(call align/$(1)) > $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
- cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
+ cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
$(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin)
endef