aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-12-03 16:57:23 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-12-03 16:57:23 +0000
commitc7c70fbb89f0f14a69c168d9919458afa34f734d (patch)
tree9c844a857318eab6df73805748ccb2bd5f156ef2 /target/linux/ar71xx
parent2af6a7d4c43e216911c3b355579dabef85ea2e4a (diff)
downloadmaster-187ad058-c7c70fbb89f0f14a69c168d9919458afa34f734d.tar.gz
master-187ad058-c7c70fbb89f0f14a69c168d9919458afa34f734d.tar.bz2
master-187ad058-c7c70fbb89f0f14a69c168d9919458afa34f734d.zip
ar71xx: create initramfs images for the newer TP-Link boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29410 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 73f816f4da..411fd16296 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -308,6 +308,14 @@ define Image/Build/TPLINK-LZMA
-o $(call sysupname,$(1),$(2))
endef
+define Image/Build/TPLINK-LZMA/initramfs
+ $(call PatchKernelLzma,$(2),$(3))
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw -c \
+ -B $(4) -N OpenWrt -V $(REVISION) -s \
+ -k $(KDIR)/vmlinux-$(2).bin.lzma \
+ -o $(call imgname,$(1),$(2))-uImage.bin
+endef
+
define Image/Build/CyberTAN
$(call MkuImageGzip,$(2),$(3))
$(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR)/vmlinux-$(2).uImage \