aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-05-30 16:19:30 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-05-30 16:19:30 +0000
commitb35eea4aeab0921052557fd962d57c434dde389e (patch)
tree724242d2be1c9e06ceb20cc520e54fa9a06fee91 /target/linux/ar71xx
parent9a188388ce737a2a9bf2bd31a1c675a2c54e0b97 (diff)
downloadmaster-187ad058-b35eea4aeab0921052557fd962d57c434dde389e.tar.gz
master-187ad058-b35eea4aeab0921052557fd962d57c434dde389e.tar.bz2
master-187ad058-b35eea4aeab0921052557fd962d57c434dde389e.zip
ar71xx: add profile and build image for the DIR-601-B1
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36786 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/generic/profiles/d-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile1
2 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/d-link.mk b/target/linux/ar71xx/generic/profiles/d-link.mk
index f30e9b1ecb..47a6bec9c5 100644
--- a/target/linux/ar71xx/generic/profiles/d-link.mk
+++ b/target/linux/ar71xx/generic/profiles/d-link.mk
@@ -27,6 +27,17 @@ endef
$(eval $(call Profile,DIR601A1))
+define Profile/DIR601B1
+ NAME:=D-Link DIR-601 rev. B1
+ PACKAGES:=
+endef
+
+define Profile/DIR601B1/Description
+ Package set optimized for the D-Link DIR-601 rev. B1.
+endef
+
+$(eval $(call Profile,DIR601B1))
+
define Profile/DIR615C1
NAME:=D-Link DIR-615 rev. C1
PACKAGES:=
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 774aab24dd..868a667c60 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -862,6 +862,7 @@ $(eval $(call SingleProfile,Cameo913x,$(fs_squash),TEW652BRP_FW,tew-652brp,TEW-6
$(eval $(call SingleProfile,Cameo913x,$(fs_squash),TEW652BRP_RECOVERY,tew-652brp-recovery,TEW-632BRP,ttyS0,115200,"AP81-AR9130-RT-070614-02"))
$(eval $(call SingleProfile,Cameo933x,$(fs_squash),TEW712BR,tew-712br,TEW-712BR,ttyATH0,115200,"HORNET-RT-TEW712BR-3",1.99,""))
+$(eval $(call SingleProfile,Cameo933x,$(fs_squash),DIR601B1,dir-601-b1,TEW-712BR,ttyATH0,115200,"HORNET-RT-DIR601B1-3",2.99.99,"" "NA"))
$(eval $(call SingleProfile,Cameo934x,$(fs_64k),DIR825C1,dir-825-c1,DIR-825-C1,ttyS0,115200,"00DB120AR9344-RT-101214-00"))
$(eval $(call SingleProfile,Cameo934x,$(fs_64k),DIR835A1,dir-835-a1,DIR-835-A1,ttyS0,115200,"00DB120AR9344-RT-101214-00"))