aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-23 12:14:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-23 12:14:18 +0000
commit94af2f3b5ab6f9b5a2308d64ea0b373ca8c88810 (patch)
treeb47d890ad48e7a5cc75fd2484e196a4e841279fa /target/linux/ar71xx
parent11ede132116d3be88b3ac88f057ccab33e4af642 (diff)
downloadmaster-187ad058-94af2f3b5ab6f9b5a2308d64ea0b373ca8c88810.tar.gz
master-187ad058-94af2f3b5ab6f9b5a2308d64ea0b373ca8c88810.tar.bz2
master-187ad058-94af2f3b5ab6f9b5a2308d64ea0b373ca8c88810.zip
ar71xx: image: build Planex kernels in a separate step
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38137 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 6f64b13390..03f1031c2d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -530,7 +530,7 @@ endef
Image/Build/Planex/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2) $(planex_mtdlayout),0x52000,0)
-define Image/Build/Planex
+define Image/Build/Planex/buildkernel
[ -e "$(KDIR)/loader-$(2).gz" ]
$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
$(call MkuImageOKLI,$(2))
@@ -538,6 +538,9 @@ define Image/Build/Planex
dd if=$(KDIR_TMP)/vmlinux-$(2).uImage bs=8k count=1 conv=sync; \
dd if=$(KDIR_TMP)/vmlinux-$(2).okli; \
) > $(KDIR_TMP)/kernel-$(2).bin
+endef
+
+define Image/Build/Planex
$(call Sysupgrade/KR,$(1),$(KDIR_TMP)/kernel-$(2).bin,1048576,6750208,$(2))
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
$(STAGING_DIR_HOST)/bin/mkplanexfw \