aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-02-18 17:34:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-02-18 17:34:16 +0000
commit8ed16ce49af4c63c4a495b1d9d040a64e6e1936a (patch)
tree4e7a16ee486bb3e143f83884d4904c04f63a857d /target/linux/ar71xx
parent216641d3c0a617ef964c0a89c046ea7a3ecc06ce (diff)
downloadmaster-187ad058-8ed16ce49af4c63c4a495b1d9d040a64e6e1936a.tar.gz
master-187ad058-8ed16ce49af4c63c4a495b1d9d040a64e6e1936a.tar.bz2
master-187ad058-8ed16ce49af4c63c4a495b1d9d040a64e6e1936a.zip
ar71xx: WNR2200: fix mounting root fs problem
Solves ticket #14356 <https://dev.openwrt.org/ticket/14356> Without this patch, UART output will show only 4 partitions: [ 0.740000] 4 cmdlinepart partitions found on MTD device spi0.0 [ 0.750000] Creating 4 MTD partitions on "spi0.0": [ 0.750000] 0x000000000000-0x000000050000 : "u-boot" [ 0.760000] 0x000000050000-0x000000070000 : "u-boot-env" [ 0.770000] 0x000000070000-0x0000007f0000 : "firmware" [ 0.790000] 0x0000007f0000-0x000000800000 : "art" and then linux complains :VFS: Cannot open root device "(null)" With this patch, UART out will show 7 partitions: [ 0.740000] 4 cmdlinepart partitions found on MTD device spi0.0 [ 0.750000] Creating 4 MTD partitions on "spi0.0": [ 0.750000] 0x000000000000-0x000000040000 : "u-boot" [ 0.760000] 0x000000040000-0x000000050000 : "u-boot-env" [ 0.770000] 0x000000050000-0x0000007f0000 : "firmware" [ 0.780000] 2 netgear-fw partitions found on MTD device firmware [ 0.780000] 0x000000050000-0x00000014b440 : "kernel" [ 0.790000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only [ 0.800000] 0x00000014b440-0x0000007f0000 : "rootfs" [ 0.810000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only [ 0.820000] mtd: device 4 (rootfs) set to be root filesystem [ 0.830000] 1 squashfs-split partitions found on MTD device rootfs [ 0.830000] 0x000000340000-0x0000007f0000 : "rootfs_data" [ 0.840000] 0x0000007f0000-0x000000800000 : "art" This patch is tested against r39502 of trunk. Signed-off-by: Jonathan Chang <changcs@santos.ee.ntu.edu.tw> Patchwork: http://patchwork.openwrt.org/patch/4870/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 9076f22ff0..a2dcd1ddad 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -234,7 +234,7 @@ ubdev_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7488k(firmware)
whrhpg300n_mtdlayout=mtdparts=spi0.0:248k(u-boot)ro,8k(u-boot-env)ro,3712k(firmware),64k(art)ro
wlr8100_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),14080k(rootfs),192k(unknown)ro,64k(art)ro,384k(unknown2)ro,15488k@0x40000(firmware)
wndap360_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1728k(kernel),6016k(rootfs),64k(nvram)ro,64k(art)ro,7744k@0x50000(firmware)
-wnr2200_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,7680k(firmware),64k(art)ro
+wnr2200_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7808k(firmware),64k(art)ro
wnr2000v3_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,3712k(firmware),64k(art)ro
wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,7680k(firmware),64k(art)ro
wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,15872k(firmware),64k(art)ro