aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-03-27 09:28:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-03-27 09:28:33 +0000
commit4d85ad8010a6b66a9982c02497e0c8c381cc6624 (patch)
treefe94818d5fcddcb5a1458d99a57c8cb909c97aa9 /target/linux/ar71xx
parent06640cbff58c3c9c2074180a6794f777b824982d (diff)
downloadmaster-187ad058-4d85ad8010a6b66a9982c02497e0c8c381cc6624.tar.gz
master-187ad058-4d85ad8010a6b66a9982c02497e0c8c381cc6624.tar.bz2
master-187ad058-4d85ad8010a6b66a9982c02497e0c8c381cc6624.zip
kernel: update 3.10 to 3.10.34
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40291 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.10/200-spi-ath79-fix-initial-GPIO-CS-line-setup.patch37
2 files changed, 1 insertions, 38 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index d8a484e00a..fe54a52343 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=mips16
CPU_TYPE=34kc
SUBTARGETS:=generic nand mikrotik
-LINUX_VERSION:=3.10.32
+LINUX_VERSION:=3.10.34
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/patches-3.10/200-spi-ath79-fix-initial-GPIO-CS-line-setup.patch b/target/linux/ar71xx/patches-3.10/200-spi-ath79-fix-initial-GPIO-CS-line-setup.patch
deleted file mode 100644
index 46657940b8..0000000000
--- a/target/linux/ar71xx/patches-3.10/200-spi-ath79-fix-initial-GPIO-CS-line-setup.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 3a7853f0dd24e81dc920c98a5c7e8cfdde81bb45 Mon Sep 17 00:00:00 2001
-From: Gabor Juhos <juhosg@openwrt.org>
-Date: Thu, 16 Jan 2014 16:58:58 +0100
-Subject: [PATCH] spi-ath79: fix initial GPIO CS line setup
-
-The 'ath79_spi_setup_cs' function initializes the chip
-select line of a given SPI device in order to make sure
-that the device is inactive.
-
-If the SPI_CS_HIGH bit is set for a given device, it
-means that the CS line of that device is active HIGH
-so it must be set to LOW initially. In case of GPIO
-CS lines, the 'ath79_spi_setup_cs' function does the
-opposite of that due to the wrong GPIO flags.
-
-Fix the code to use the correct GPIO flags.
-
-Reported-by: Ronald Wahl <ronald.wahl@raritan.com>
-Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
----
- drivers/spi/spi-ath79.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/drivers/spi/spi-ath79.c
-+++ b/drivers/spi/spi-ath79.c
-@@ -132,9 +132,9 @@ static int ath79_spi_setup_cs(struct spi
-
- flags = GPIOF_DIR_OUT;
- if (spi->mode & SPI_CS_HIGH)
-- flags |= GPIOF_INIT_HIGH;
-- else
- flags |= GPIOF_INIT_LOW;
-+ else
-+ flags |= GPIOF_INIT_HIGH;
-
- status = gpio_request_one(cdata->gpio, flags,
- dev_name(&spi->dev));