aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-25 17:52:12 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-25 17:52:12 +0000
commit2499202417dc4bc88d7ac4beecc49c6acade1601 (patch)
treef43c3efefc91c782529631a9c83625113d222726 /target/linux/ar71xx/profiles
parentca40d416f7ce6f9a4a8dfb9c77a21c7163c7545e (diff)
downloadmaster-187ad058-2499202417dc4bc88d7ac4beecc49c6acade1601.tar.gz
master-187ad058-2499202417dc4bc88d7ac4beecc49c6acade1601.tar.bz2
master-187ad058-2499202417dc4bc88d7ac4beecc49c6acade1601.zip
[ar71xx] create firmware image for the RouterStation Pro, and add a profile for it (patch by Ubiquiti Networks)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16066 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/profiles')
-rw-r--r--target/linux/ar71xx/profiles/ubnt.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/profiles/ubnt.mk b/target/linux/ar71xx/profiles/ubnt.mk
index ac9ef3619d..849e3c2edd 100644
--- a/target/linux/ar71xx/profiles/ubnt.mk
+++ b/target/linux/ar71xx/profiles/ubnt.mk
@@ -15,3 +15,25 @@ define Profile/UBNTRS/Description
endef
$(eval $(call Profile,UBNTRS))
+
+define Profile/UBNTRSPRO
+ NAME:=Ubiquiti RouterStation Pro
+ PACKAGES:=kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTRSPRO/Description
+ Package set optimized for the Ubiquiti RouterStation Pro.
+endef
+
+$(eval $(call Profile,UBNTRSPRO))
+
+define Profile/UBNT
+ NAME:=Ubiquiti Products
+ PACKAGES:=kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNT/Description
+ Build images for all Ubiquiti products (including LS-SR71, RouterStation and RouterStation Pro)
+endef
+
+$(eval $(call Profile,UBNT))