aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-28 17:47:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-28 17:47:33 +0000
commit0a88a341f2acec5db710a5310b7f05d6dd7a59a0 (patch)
treee90ff010c55a1f6069e5ad29d9580a064e34fe8f /target/linux/ar71xx/profiles
parentf62328db0eb2cc440a9b44df1a8295b7fdb452ca (diff)
downloadmaster-187ad058-0a88a341f2acec5db710a5310b7f05d6dd7a59a0.tar.gz
master-187ad058-0a88a341f2acec5db710a5310b7f05d6dd7a59a0.tar.bz2
master-187ad058-0a88a341f2acec5db710a5310b7f05d6dd7a59a0.zip
[ar71xx] add initial profiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14693 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/profiles')
-rw-r--r--target/linux/ar71xx/profiles/00-default.mk16
-rw-r--r--target/linux/ar71xx/profiles/compex.mk17
-rw-r--r--target/linux/ar71xx/profiles/d-link.mk17
-rw-r--r--target/linux/ar71xx/profiles/planex.mk17
-rw-r--r--target/linux/ar71xx/profiles/tp-link.mk17
-rw-r--r--target/linux/ar71xx/profiles/trendnet.mk28
-rw-r--r--target/linux/ar71xx/profiles/ubnt.mk17
7 files changed, 129 insertions, 0 deletions
diff --git a/target/linux/ar71xx/profiles/00-default.mk b/target/linux/ar71xx/profiles/00-default.mk
new file mode 100644
index 0000000000..5b9df1d560
--- /dev/null
+++ b/target/linux/ar71xx/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default
+ PACKAGES:=
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/ar71xx/profiles/compex.mk b/target/linux/ar71xx/profiles/compex.mk
new file mode 100644
index 0000000000..468c25179e
--- /dev/null
+++ b/target/linux/ar71xx/profiles/compex.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WP543
+ NAME:=Compex WP543
+ PACKAGES:=kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WP543/Description
+ Package set optimized for the Compex WP543
+endef
+
+$(eval $(call Profile,WP543))
diff --git a/target/linux/ar71xx/profiles/d-link.mk b/target/linux/ar71xx/profiles/d-link.mk
new file mode 100644
index 0000000000..0aa50a640d
--- /dev/null
+++ b/target/linux/ar71xx/profiles/d-link.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DIR615C1
+ NAME:=D-Link DIR-615 rev. C1
+ PACKAGES:=kmod-ath9k
+endef
+
+define Profile/DIR615C1/Description
+ Package set optimized for the D-Link DIR-615 rev. C1.
+endef
+
+$(eval $(call Profile,DIR615C1))
diff --git a/target/linux/ar71xx/profiles/planex.mk b/target/linux/ar71xx/profiles/planex.mk
new file mode 100644
index 0000000000..df92b1670e
--- /dev/null
+++ b/target/linux/ar71xx/profiles/planex.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MZKW04NU
+ NAME:=Planex MZK-W04NU
+ PACKAGES:=kmod-ath9k kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/MZKW04NU/Description
+ Package set optimized for the Planex MZK-W04NU.
+endef
+
+$(eval $(call Profile,MZKW04NU))
diff --git a/target/linux/ar71xx/profiles/tp-link.mk b/target/linux/ar71xx/profiles/tp-link.mk
new file mode 100644
index 0000000000..db60e1d1f7
--- /dev/null
+++ b/target/linux/ar71xx/profiles/tp-link.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TLWR941ND
+ NAME:=TP-LINK TL-WR941ND
+ PACKAGES:=kmod-ath9k
+endef
+
+define Profile/TLWR941ND/Description
+ Package set optimized for the TP-LINK TL-WR941ND.
+endef
+
+$(eval $(call Profile,TLWR941ND))
diff --git a/target/linux/ar71xx/profiles/trendnet.mk b/target/linux/ar71xx/profiles/trendnet.mk
new file mode 100644
index 0000000000..3a40fbcaee
--- /dev/null
+++ b/target/linux/ar71xx/profiles/trendnet.mk
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TEW632BRP
+ NAME:=TRENDNet TEW-632BRP
+ PACKAGES:=kmod-ath9k
+endef
+
+define Profile/TEW632BRP/Description
+ Package set optimized for the TRENDNet TEW-632BRP.
+endef
+
+$(eval $(call Profile,TEW632BRP))
+
+define Profile/TEW652BRP
+ NAME:=TRENDNet TEW-652BRP
+ PACKAGES:=kmod-ath9k
+endef
+
+define Profile/TEW652BRP/Description
+ Package set optimized for the TRENDNet TEW-652BRP.
+endef
+
+$(eval $(call Profile,TEW652BRP))
diff --git a/target/linux/ar71xx/profiles/ubnt.mk b/target/linux/ar71xx/profiles/ubnt.mk
new file mode 100644
index 0000000000..e7b20deaa0
--- /dev/null
+++ b/target/linux/ar71xx/profiles/ubnt.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UBNTRS
+ NAME:=Ubiquiti RouterStation
+ PACKAGES:=kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTRS/Description
+ Package set optimized for the Ubiquiti RouterStation
+endef
+
+$(eval $(call Profile,UBNTRS))