aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-12-08 12:46:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-12-08 12:46:25 +0000
commit00c14fd8659954304a48a19547a4dc1bb7a125f2 (patch)
treea44fa87fb3c9d520b8eb653cf1d5817f8fd60c01 /target/linux/ar71xx/profiles
parent65ffc1bc61be09a828a361c68f754284f5ba9d21 (diff)
downloadmaster-187ad058-00c14fd8659954304a48a19547a4dc1bb7a125f2.tar.gz
master-187ad058-00c14fd8659954304a48a19547a4dc1bb7a125f2.tar.bz2
master-187ad058-00c14fd8659954304a48a19547a4dc1bb7a125f2.zip
ar71xx: preliminary support for the TL-WR1043ND
Adds board support for the TP-Link TL-WR1043ND Based on the Atheros AP81 platform. Presently the RTL8366RB switch support is missing due to no driver. The ethernet works with 5 ports@1Gbit but is missing vlan support. Hope Ive done this right, First time submiting a patch. Signed-off-by: Andrew Tarabaras <andrew@advancedtechnologies.com.au> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18696 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/profiles')
-rw-r--r--target/linux/ar71xx/profiles/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/profiles/tp-link.mk b/target/linux/ar71xx/profiles/tp-link.mk
index ab5ed54ca5..d62ab8a7c6 100644
--- a/target/linux/ar71xx/profiles/tp-link.mk
+++ b/target/linux/ar71xx/profiles/tp-link.mk
@@ -47,3 +47,14 @@ define Profile/TLWR941NDV2/Description
endef
$(eval $(call Profile,TLWR941NDV2))
+
+define Profile/TLWR1043NDV1
+ NAME:=TP-LINK TL-WR1043ND v1
+ PACKAGES:=kmod-ath9k hostapd-mini
+endef
+
+define Profile/TLWR1043NDV1/Description
+ Package set optimized for the TP-LINK TL-WR1043ND v1.
+endef
+
+$(eval $(call Profile,TLWR1043NDV1))